Ask Your Question
0

Forcing mtu to 1400 via /etc/neutron/dnsmasq-neutron.conf per DanielS

asked 2014-02-25 13:35:49 -0600

dbaxps gravatar image

updated 2014-02-27 16:49:17 -0600

smaffulli gravatar image

Quoting Closed question

Edit the file: /etc/quantum/dhcp_agent.ini and set:
dnsmasq_config_file=/etc/neutron/dnsmasq-neutron.conf
Create and edit file /etc/neutron/dnsmasq-neutron.conf and put this inside:
dhcp-option-force=26,1400
Restart DHCP:
service neutron-dhcp-agent restart
And reboot your instance. Verify that your MTU is 1400

Doesn't work for me on "Two Node (Controller+Compute) Neutron GRE+OVS+Gluster Cluster" on F20 boxes with Havana manually installed via native repos. Have to run ifconfig eth0 mtu 1400 up via /etc/rc.d/rc.local to set the MTU to 1400.

edit retag flag offensive close merge delete

Comments

what did not work ? This option did not work ? or service did not come up ?

dheeru ( 2014-02-25 20:43:01 -0600 )edit

No , service restarted fine. Option is ignored. If it would work it would make things with ssh connections to new instances much easier than I do it right now.

dbaxps ( 2014-02-26 01:41:23 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-02-28 06:33:03 -0600

foexle gravatar image

Hi,

Kill DNSMASQ: killall dnsmasq

Restart DHCP: service neutron-dhcp-agent restart

Dnsmasq will not load new configuration without killing.

Cheers Heiko

edit flag offensive delete link more

Comments

I restarted box. So , dnsmasq processes restarted also with new config. It didn't help.

dbaxps ( 2014-02-28 11:47:49 -0600 )edit

Which interface driver and dhcp driver you are using ? check in your dhcp agent config file

foexle ( 2014-03-07 03:41:18 -0600 )edit

[root@dallas1 neutron(keystone_admin)]$ cat dhcp_agent.ini | grep -v ^# |grep -v ^$
[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
handle_internal_only_routers = TRUE
external_network_bridge = br-ex
ovs_use_veth = True
use_namespaces = True
dmasq_config_file = /etc/neutron/dnsmasq.conf
The last file was obviously updated

dbaxps ( 2014-03-07 04:20:03 -0600 )edit

I'm missing you dhcp_driver, maybe it this a default option: dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq In addition you're using veth interfaces ?! I don't know if this have an impact.

foexle ( 2014-03-07 04:43:31 -0600 )edit
-1

answered 2014-03-16 04:47:21 -0600

dbaxps gravatar image

Thanks a lot. It was just a typo in dhcp_agent.ini in line :- dnsmasq_config_file = /etc/neutron/dnsmasq.conf This typo clearly shows up in previous comment : dmasq_config_file = /etc/neutron/dnsmasq.conf <- wrong Last line from dnsmasq.log :- Mar 16 13:35:08 dnsmasq-dhcp[26111]: 1830014980 sent size: 2 option: 26 mtu 1454 Thank you once again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-02-25 13:35:49 -0600

Seen: 2,341 times

Last updated: Feb 28 '14