Heat (Stein) create stack fails on nics

asked 2019-10-29 14:26:17 -0500

Daryl gravatar image

updated 2019-10-29 14:26:44 -0500

My first effort to create a stack using Heat failed, and I'd appreciate any tips on how to get past that.

My source is the Stein Heat Getting Started page, https://docs.openstack.org/heat/stein.... I have created a Controller and two Compute nodes using the Stein installation guides (Ubuntu).

My first issue was in not being able to wget the Fedora image referenced in the Getting Started page. I found an almost-similarly named image at https://archives.fedoraproject.org/pu... and used it instead.

Then I discovered that not having a flavor was slowing me down, so I created one:

$ openstack flavor create --disk 3 m1.small

Then the create command:

$ openstack stack create \
  -t http://git.openstack.org/cgit/openstack/heat-templates/plain/hot/F20/WordPress_Native.yaml \
  --parameter key_name=heat_key --parameter image_id=fedora-20.x86_64 \
  --parameter instance_type=m1.small \
  teststack

Here is the result:

$ openstack stack event list teststack

2019-10-28 17:03:03Z [teststack]: CREATE_IN_PROGRESS  Stack CREATE started
2019-10-28 17:03:03Z [teststack.wordpress_instance]: CREATE_IN_PROGRESS  state changed
2019-10-28 17:03:03Z [teststack.wordpress_instance]: CREATE_FAILED  ValueError: resources.wordpress_instance: nics are required after microversion 2.36
2019-10-28 17:03:03Z [teststack]: CREATE_FAILED  Resource CREATE failed: ValueError: resources.wordpress_instance: nics are required after microversion 2.36

So does this mean I have to create some nics? If so, how? Or should I be using a different image (like the cirros image that came with the Stein Glance installation? Or something else altogether?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2019-10-29 18:36:34 -0500

What is your goal? Testing Heat after an installation? If so, you have confirmed that it works. A failing stack is proof that Heat is functional.

Or you want to learn how to write templates? Perhaps you should start small, e.g. https://docs.openstack.org/heat/lates....

Or you modify the Wordpress stack. You can use the networksproperty to add NICs: https://docs.openstack.org/heat/lates....

edit flag offensive delete link more
0

answered 2019-10-29 21:22:16 -0500

Daryl gravatar image

I need to study the communications burden between the Controller and the Compute nodes created by orchestration services (my environment is bandwidth-limited). Your tip about the networks property should get me over the hump. The "start small" idea is why I started with the Getting Started page and then tried the HOT Hello World page, which gave the same error.

Thanks again for the feedback.

edit flag offensive delete link more
0

answered 2019-10-30 07:02:38 -0500

user_2019_10_18_20_02 gravatar image

You don't have a networks parameter in your OS::Nova::Server resource section, this will be needed for having nic configuration of your VM. You have to find out the network to which the VM has to attach upon spawning. Something like below in your nova compute resource section

networks: public_net or private_net

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-10-29 14:26:17 -0500

Seen: 177 times

Last updated: Oct 29 '19