Error while installing one node

asked 2019-10-21 02:43:04 -0600

anonymous user

Anonymous

We are doing the instalaltion of openstack and very new to the openstack world. For RD purpose we trying to install openstack on 1node server. Below is the error thrown while installing

Applying <ip>_controller.pp <ip>_controller.pp: [ ERROR ] Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: <ip>_controller.pp Error: Function lookup() did not find a value for the name 'NO_ROOT_USER_ALLINONE' You will find full trace in log /var/tmp/packstack/20191021-131606-y3grTx/manifests/<ip>_controller.pp.log Please check log file /var/tmp/packstack/20191021-131606-y3grTx/openstack-setup.log for more information Additional information: * Parameter CONFIG_NEUTRON_L2_AGENT: You have choosen OVN neutron backend. Note that this backend does not support LBaaS, VPNaaS or FWaaS services. Geneve will be used as encapsulation method for tenant networks * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components. * Warning: NetworkManager is active on <ip>. OpenStack networking currently does not work on systems that have the Network Manager service enabled. * To access the OpenStack Dashboard browse to http://<ip>/dashboard . Please, find your login credentials stored in the keystonerc_admin in your home directory.

edit retag flag offensive close merge delete

Comments

Not sure if this is related, but you have NetworkManager running, which is deadly for Packstack in my experience.

Also, check the log files mentioned in the error message.

Bernd Bausch gravatar imageBernd Bausch ( 2019-10-21 04:27:09 -0600 )edit