Ask Your Question
0

Ubuntu_Cinder_Specified key was too long; max key length is 767 bytes

asked 2019-10-09 03:56:26 -0600

Behzad_1992 gravatar image

Hi all

I am trying to install Cinder on the Controller node. When I've tried to populate the Cinder database, the following error is shown:

root@controller1:/etc/mysql/mariadb.conf.d# su -s /bin/sh -c "cinder-manage db sync" cinder the ouput with error is attached to the following link: http://paste.openstack.org/show/782286/

The error is: "*pymysql.err.InternalError: (1071, 'Specified key was too long; max key length is 767 bytes') 2019-10-09 03:39:56.899 12735 ERROR oslo_db.sqlalchemy.exc_filters *

Here are my Openstack DB configuration file:

root@controller1:/etc/mysql/mariadb.conf.d# cat 99-openstack.cnf [mysqld] bind-address = 10.10.13.110 default-storage-engine = innodb innodb_file_per_table = on max_connections = 4096 collation-server = utf8_general_ci character-set-server = utf8

root@controller1:/etc/mysql/mariadb.conf.d# lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.3 LTS Release: 18.04 Codename: bionic

root@controller1:/etc/mysql/mariadb.conf.d# apt show cinder-api Package: cinder-api Version: 2:14.0.0-0ubuntu1~cloud0

any help of feedback is much appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-10-12 10:08:10 -0600

Behzad_1992 gravatar image

anyone?!!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-10-09 03:54:06 -0600

Seen: 28 times

Last updated: Oct 09