Ask Your Question
0

TypeError: __init__() takes exactly 2 arguments (1 given)

asked 2019-10-07 07:41:27 -0500

madness31 gravatar image

updated 2019-10-08 08:45:22 -0500

I installed openstack using maas and juju using openstack-base bundle (https://jaas.ai/openstack-base) and everything worked smooth. Futhermore, I installed Zun and kuryr-libnetwork manually https://docs.openstack.org/zun/latest/install/ (https://docs.openstack.org/zun/latest...), https://docs.openstack.org/kuryr-libnetwork/latest/install/ (https://docs.openstack.org/kuryr-libn...). Now I tried to install zun-ui plugin for horizon dashboard using this (https://docs.openstack.org/zun-ui/latest/install/index.html (https://docs.openstack.org/zun-ui/lat...))

After restarting apache2 service I got Internal server error 500 on horizon web page and this error in /var/log/apache2/error.log:

[Mon Oct 07 12:14:56.934663 2019] [wsgi:error] [pid 22044:tid 139935939966720] [remote 10.1.1.65:53754] File "/usr/local/lib/python2.7/dist-packages/django/core/handlers/base.py", line 58, in load_middleware [Mon Oct 07 12:14:56.934795 2019] [wsgi:error] [pid 22044:tid 139935939966720] [remote 10.1.1.65:53754] mw_instance = mw_class() [Mon Oct 07 12:14:56.934829 2019] [wsgi:error] [pid 22044:tid 139935939966720] [remote 10.1.1.65:53754] TypeError: __init__() takes exactly 2 arguments (1 given)

I know that previously some user had a similar problem (https://ask.openstack.org/en/question/56548/typeerror-__init__-takes-exactly-2-arguments-1-given/ (https://ask.openstack.org/en/question...)), but I do use Stein version and horizon requirements are met (assigned bellow)

https://github.com/openstack/horizon/blob/stable/stein/requirements.txt (https://github.com/openstack/horizon/...)

Pip freeze output is here:

amqp==2.2.2 anyjson==0.3.3 appdirs==1.4.3 asn1crypto==0.24.0 Babel==2.7.0 backports.ssl-match-hostname==3.7.0.1 beautifulsoup4==4.6.0 blinker==1.4 cachetools==2.0.0 certifi==2018.1.18 chardet==3.0.4 cliff==2.11.0 cmd2==0.7.9 contextlib2==0.5.5 cryptography==2.1.4 csscompressor==0.9.4 debtcollector==1.13.0 decorator==4.1.2 deprecation==1.0.1 designate-dashboard==6.0.0 Django==1.9 django-appconf==1.0.2 django-babel==0.6.2 django-compressor==2.2 django-debreach==1.5.2 django-pyscss==2.0.2 dnspython==1.15.0 docker==4.1.0 docutils==0.14 dogpile.cache==0.6.2 enum34==1.1.6 eventlet==0.20.0 extras==1.0.0 fasteners==0.12.0 fixtures==3.0.0 FormEncode==1.3.0 funcsigs==1.0.2 functools32==3.2.3.post2 futures==3.2.0 futurist==1.6.0 greenlet==0.4.12 heat-dashboard==1.0.2 horizon==16.0.0.0rc1 html5lib==0.999999999 idna==2.6 ipaddress==1.0.17 iso8601==0.1.11 Jinja2==2.10 jmespath==0.9.3 jsonpatch==1.16 jsonpointer==1.10 jsonschema==2.6.0 keyring==10.6.0 keyrings.alt==3.0 keystoneauth1==3.4.0 kombu==4.1.0 linecache2==1.0.0 lxml==4.2.1 MarkupSafe==1.0 mock==2.0.0 monotonic==1.0 msgpack==0.5.6 munch==2.2.0 netaddr==0.7.19 netifaces==0.10.4 neutron-fwaas-dashboard==1.3 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-10-08 08:59:38 -0500

madness31 gravatar image

updated 2019-10-09 05:43:37 -0500

Maybe problem is because of dependencies? In that case, could someone post pip freeze command output on openstack stein release openstack dashboard (horizon) node. I even tried to install horizon manually (https://docs.openstack.org/horizon/stein/install/install-ubuntu.html (https://docs.openstack.org/horizon/st...)), but I got same result.

Already checked zun-ui to stable/stein and did all of these steps (https://docs.openstack.org/zun-ui/latest/install/index.html (https://docs.openstack.org/zun-ui/lat...)) still no result

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-10-07 07:41:27 -0500

Seen: 42 times

Last updated: Oct 09