Ask Your Question
0

metadata agent throwing AttributeError: 'HTTPClient' object has no attribute 'auth_tenant_id' with latest release

asked 2014-02-24 13:37:51 -0500

anonymous user

Anonymous

We are facing following issue with the metadata agent.

Errors in neutron-metadata-agent.log

neutron.agent.metadata.agent AttributeError: 'HTTPClient' object has no attribute 'auth_tenant_id'

Errors at the vm side

HTTPError: HTTP Error 500: Internal Server Error 2014-02-22 19:24:30,169 - utils.py[ERROR]: Caught exception reading instance data Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/boto/utils.py", line 219, in retry_url r = opener.open(req) File "/usr/lib64/python2.6/urllib2.py", line 397, in open response = meth(req, response) File "/usr/lib64/python2.6/urllib2.py", line 510, in http_response 'http', request, response, code, msg, hdrs) File "/usr/lib64/python2.6/urllib2.py", line 435, in error return self._call_chain(args) File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain result = func(args) File "/usr/lib64/python2.6/urllib2.py", line 518, in http_error_default raise HTTPError(req.get_full_url(), code, msg, hdrs, fp) HTTPError: HTTP Error 500: Internal Server Error 2014-02-22 19:25:34,285 - utils.py[ERROR]: Caught exception reading instance data Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/boto/utils.py", line 219, in retry_url r = opener.open(req) File "/usr/lib64/python2.6/urllib2.py", line 397, in open response = meth(req, response) File "/usr/lib64/python2.6/urllib2.py", line 510, in http_response 'http', request, response, code, msg, hdrs) File "/usr/lib64/python2.6/urllib2.py", line 435, in error return self._call_chain(args) File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain result = func(args) File "/usr/lib64/python2.6/urllib2.py", line 518, in http_error_default raise HTTPError(req.get_full_url(), code, msg, hdrs, fp) HTTPError: HTTP Error 500: Internal Server Error

The original rdo installed version was python-neutronclient-2.3.1-2.el6.noarch and we tried to upgrade this to python-neutronclient-2.3.3-1.el6.noarch.rpm

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-02-24 14:46:29 -0500

kfox1111 gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-02-24 13:37:51 -0500

Seen: 406 times

Last updated: Feb 24 '14