Can't Resolve nova-api Error

asked 2019-09-24 00:32:47 -0600

kapibara gravatar image

Hi, I Build openstack environment based on Official install guide's 'minimum deployment for stein. use component is Keystone,Glance,Nova,Neutron,Placement,Horizon. I get three errors when I open the dashboard. Error is

Error: Unable to retrieve usage information.

Error: Unable to retrieve compute limit information.

Error: Unable to retrieve limits information.

At that time, the log of nova-api is as follows

2019-09-24 14:14:36.669 7499 WARNING keystoneauth.identity.generic.base [-] Failed to discover available identity versions when contacting http://controller:35357. Attempting to parse version from URL.: keystoneauth1.exceptions.connection.ConnectFailure: Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602e49c88="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) 2019-09-24 14:14:36.734 7499 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602e49c88="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)): keystoneauth1.exceptions.discovery.DiscoveryFailure: Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602e49c88="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) 2019-09-24 14:14:36.772 7499 INFO nova.osapi_compute.wsgi.server [-] 192.168.10.200 "GET /v2.1/extensions HTTP/1.1" status: 503 len: 498 time: 0.2240658 2019-09-24 14:14:38.800 7499 WARNING keystoneauth.identity.generic.base [-] Failed to discover available identity versions when contacting http://controller:35357. Attempting to parse version from URL.: keystoneauth1.exceptions.connection.ConnectFailure: Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602db16a0="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) 2019-09-24 14:14:38.802 7499 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602db16a0="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)): keystoneauth1.exceptions.discovery.DiscoveryFailure: Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7ff602db16a0="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) 2019-09-24 14:14:38.805 7499 INFO nova.osapi_compute.wsgi.server [-] 192.168.10.200 "GET /v2.1/limits?reserved=1 HTTP/1.1" status ...

(more)
edit retag flag offensive close merge delete

Comments

Please don't use quotes but code tags to format your question. There's something wrong with your authentication as the logs say:Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Double check your url's, is apache running?

eblock gravatar imageeblock ( 2019-09-24 01:57:59 -0600 )edit

Sorry,I'm not used to it yet. I confirmed that apache2 was moving.

kapibara gravatar imagekapibara ( 2019-09-24 09:38:26 -0600 )edit

You can always edit your question to change the format ;-) What do you mean "apache2 was moving"? Has your issue been resolved? If so could you close your question and mark is as "solved"?

eblock gravatar imageeblock ( 2019-09-25 05:34:34 -0600 )edit

ok edit it. not resolved. Confirmed because you asked 'is apache running?' I'm sorry if I made a mistake. I am not good at English.

kapibara gravatar imagekapibara ( 2019-09-25 09:52:44 -0600 )edit

using url is apache running.

kapibara gravatar imagekapibara ( 2019-09-25 09:53:05 -0600 )edit