Openstack instances can't ping to internet

asked 2019-09-21 09:35:20 -0600

sami 45215 gravatar image

I install openstack on single node using this guide https://docs.openstack.org/install-guide/ (https://docs.openstack.org/install-gu...) . When I launch an instance from OpenStack, the DHCP gives it a private IP 172.30.2.107. From that instance, I can ping the OpenStack host 172.30.2.219. I can't ping any other network outside of 172.30.2.0/24 and I can't ping 8.8.8.8.

the ip addr command output :

1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 9001 qdisc mq master brq49c51ee0-07 state UP group default qlen 1000 link/ether 0a:ba:5e:71:a6:f2 brd ff:ff:ff:ff:ff:ff inet6 fe80::8ba:5eff:fe71:a6f2/64 scope link valid_lft forever preferred_lft forever 3: virbr0: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc noqueue state DOWN group default qlen 1000 link/ether 52:54:00:bd:c2:82 brd ff:ff:ff:ff:ff:ff inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0 valid_lft forever preferred_lft forever 4: virbr0-nic: <broadcast,multicast> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000 link/ether 52:54:00:bd:c2:82 brd ff:ff:ff:ff:ff:ff 5: brq49c51ee0-07: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP group default qlen 1000 link/ether 0a:ba:5e:71:a6:f2 brd ff:ff:ff:ff:ff:ff inet 172.30.2.219/24 brd 172.30.2.255 scope global brq49c51ee0-07 valid_lft forever preferred_lft forever 6: tapdbcceff1-c4@if2: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue master brq49c51ee0-07 state UP group default qlen 1000 link/ether ce:e1:9b:7f:fd:00 brd ff:ff:ff:ff:ff:ff link-netnsid 0

edit retag flag offensive close merge delete

Comments

Your single node doesn't have an IP address (except for the self-configured IPv6 address on eth0). It doesn't look like it is connected to the internet at all, so you should not be surprised that the instance can't reach the internet.

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-21 10:27:56 -0600 )edit

I can ping the internet from the openstack hosts (single node)

sami 45215 gravatar imagesami 45215 ( 2019-09-21 10:48:04 -0600 )edit

The instance is connected via a TAP interface which is plugged into bridge brq49c51ee0-07. Since this bridge is not attached to the outside network, the instance isn't either.

Can you share the linuxbridge agent configuration and the details of the cloud's external network?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-21 10:58:20 -0600 )edit

I install Opestack on a virtual machine inside Amazon EC2 she has a private ip 172.30.2.219 and a public ip 63.32.44.146 .

On /etc/neutron/plugins/ml2/linuxbridge_agent.ini

[linux_bridge] physical_interface_mappings = provider:eth0

sami 45215 gravatar imagesami 45215 ( 2019-09-21 12:20:37 -0600 )edit

Sorry, I had not seen that eth0 is plugged into the bridge. Looks good from a Neutron point of view.

I would first ensure that AWS networking doesn't discard packets from your instance. For example, a random page on the internet says:

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-21 22:49:00 -0600 )edit