ContextualVersionConflict: (jsonschema 3.0.2 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('jsonschema<3.0.0,>=2.6.0'), set(['glance'])) [closed]

asked 2019-09-09 13:31:27 -0500

kurisu gravatar image

I VERY NEED YOUR HELP!!! THX!!!!

this is devstack.

i used pip install jsonschema==2.6.0, but it not work, it change to 3.0,2 and boom.

here is the error message.

Obtaining file:///opt/stack/glance ERROR: Exception: Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/pip/_internal/cli/base_command.py", line 188, in main status = self.run(options, args) File "/usr/local/lib/python2.7/dist-packages/pip/_internal/commands/install.py", line 345, in run resolver.resolve(requirement_set) File "/usr/local/lib/python2.7/dist-packages/pip/_internal/legacy_resolve.py", line 196, in resolve self._resolve_one(requirement_set, req) File "/usr/local/lib/python2.7/dist-packages/pip/_internal/legacy_resolve.py", line 359, in _resolve_one abstract_dist = self._get_abstract_dist_for(req_to_install) File "/usr/local/lib/python2.7/dist-packages/pip/_internal/legacy_resolve.py", line 291, in _get_abstract_dist_for req, self.require_hashes, self.use_user_site, self.finder, File "/usr/local/lib/python2.7/dist-packages/pip/_internal/operations/prepare.py", line 255, in prepare_editable_requirement req.check_if_exists(use_user_site) File "/usr/local/lib/python2.7/dist-packages/pip/_internal/req/req_install.py", line 418, in check_if_exists self.req.name File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 481, in get_distribution dist = get_provider(dist) File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 357, in get_provider return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0] File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 900, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 791, in resolve raise VersionConflict(dist, req).with_context(dependent_req) ContextualVersionConflict: (jsonschema 3.0.2 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('jsonschema<3.0.0,>=2.6.0'), set(['glance'])) +inc/python:pip_install:1 exit_trap +./stack.sh:exit_trap:525 local r=2 ++./stack.sh:exit_trap:526 jobs -p +./stack.sh:exit_trap:526 jobs= +./stack.sh:exit_trap:529 [[ -n '' ]] +./stack.sh:exit_trap:535 '[' -f '' ']' +./stack.sh:exit_trap:540 kill_spinner +./stack.sh:kill_spinner:435 '[' '!' -z '' ']' +./stack.sh:exit_trap:542 [[ 2 -ne 0 ]] +./stack.sh:exit_trap:543 echo 'Error on exit' Error on exit +./stack.sh:exit_trap:545 type -p generate-subunit +./stack.sh:exit_trap:546 generate-subunit 1568053387 146 fail +./stack.sh:exit_trap:548 [[ -z /opt/stack/logs ]] +./stack.sh:exit_trap:551 /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs +./stack.sh:exit_trap:560 exit 2

here is my local.conf

``` [[local|localrc]]

GIT_BASE=http://git.trystack.cn NOVNC_REPO=http://git.trystack.cn/kanaka/noVNC.git SPICE_REPO=http://git.trystack.cn/git/spice/spice-html5.git

RECLONE=True

DOWNLOAD_DEFAULT_IMAGES=False IMAGE_URLS="http://download.cirros-cloud.net/0.3.5/cirros-0.3.5-x86_64-disk.img"

HOST_IP=192.168.64.224

DATABASE_PASSWORD=stack ADMIN_PASSWORD=stack SERVICE_PASSWORD=stack SERVICE_TOKEN=stack RABBIT_PASSWORD=stack

HORIZON_BRANCH=master KEYSTONE_BRANCH=master NOVA_BRANCH=master NEUTRON_BRANCH=master GLANCE_BRANCH=master CINDER_BRANCH=master

KEYSTONE_TOKEN_FORMAT=UUID

HEAT_BRANCH=master enable_service h-eng h-api h-api-cfn h-api-cw

SWIFT_BRANCH=master ENABLED_SERVICES+=,s-proxy,s-object,s-container,s-account SWIFT_REPLICAS=1 SWIFT_HASH=011688b44136573e209e

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-l3 enable_service ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by kurisu
close date 2019-09-11 00:50:13.417573

Comments

Well, obviously a jsonschema version less than 3 is required, and your version is greater than 3.

I just checked on a Stein Devstack that I set up a few weeks ago (it's not the master version like yours). jsonschema 2.6.0 is installed.

By the way, you should fix the formatting of your question.

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-09 17:06:25 -0500 )edit

And out of curiosity: Why are you using git.trystack.cn instead of the official repository opendev.org?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-09 19:20:16 -0500 )edit

OMG! it's done! thx!

Yes, git repo path is the reason of my question! I setup openstack success when i use opendev.org!

I'm live in China , that's why i use git.trystack.cn.

About question format...... i'm sorry, the markdown renderer looks weird... it's different from github....

Thx again!

kurisu gravatar imagekurisu ( 2019-09-11 00:56:40 -0500 )edit