Ask Your Question
0

Error: No valid host was found. There are not enough hosts available

asked 2019-09-07 08:38:09 -0500

KKK gravatar image

HI,

I have verified the workarounds given in the blog regarding the same error "Error: No valid host was found. There are not enough hosts available" All looks fine in my system except one. I done the system validation using command "virt-host-validate" and its output given below. Memory and CPU mount point showing failed. Is this could be the reason for my issue ? IF so could any one please help me how to resolve that mount issue

root@mitaka-ctlnode:~# virt-host-validate QEMU: Checking for hardware virtualization : PASS QEMU: Checking if device /dev/kvm exists : PASS QEMU: Checking if device /dev/kvm is accessible : PASS QEMU: Checking if device /dev/vhost-net exists : PASS QEMU: Checking if device /dev/net/tun exists : PASS QEMU: Checking for cgroup 'memory' controller support : PASS QEMU: Checking for cgroup 'memory' controller mount-point : WARN (Mount 'memory' cgroup controller (suggested at /sys/fs/cgroup/memory)) QEMU: Checking for cgroup 'cpu' controller support : PASS QEMU: Checking for cgroup 'cpu' controller mount-point : WARN (Mount 'cpu' cgroup controller (suggested at /sys/fs/cgroup/cpu)) QEMU: Checking for cgroup 'cpuacct' controller support : PASS QEMU: Checking for cgroup 'cpuacct' controller mount-point : WARN (Mount 'cpuacct' cgroup controller (suggested at /sys/fs/cgroup/cpuacct)) QEMU: Checking for cgroup 'devices' controller support : PASS QEMU: Checking for cgroup 'devices' controller mount-point : WARN (Mount 'devices' cgroup controller (suggested at /sys/fs/cgroup/devices)) QEMU: Checking for cgroup 'net_cls' controller support : WARN (Enable CONFIG_NET_CLS_CGROUP in kernel Kconfig file) QEMU: Checking for cgroup 'blkio' controller support : PASS QEMU: Checking for cgroup 'blkio' controller mount-point : WARN (Mount 'blkio' cgroup controller (suggested at /sys/fs/cgroup/blkio)) QEMU: Checking for device assignment IOMMU support : PASS QEMU: Checking if IOMMU is enabled by kernel : WARN (IOMMU appears to be disabled in kernel. Add intel_iommu=on to kernel cmdline arguments) LXC: Checking for Linux >= 2.6.26 : PASS LXC: Checking for namespace ipc : PASS LXC: Checking for namespace mnt : PASS LXC: Checking for namespace pid : PASS LXC: Checking for namespace uts : PASS LXC: Checking for namespace net : PASS LXC: Checking for namespace user : PASS LXC: Checking for cgroup 'memory' controller support : PASS LXC: Checking for cgroup 'memory' controller mount-point : FAIL (Mount 'memory' cgroup controller (suggested at /sys/fs/cgroup/memory)) LXC: Checking for cgroup 'cpu' controller support : PASS LXC: Checking for cgroup 'cpu' controller mount-point : FAIL (Mount 'cpu' cgroup controller (suggested at /sys/fs/cgroup/cpu)) LXC: Checking for cgroup 'cpuacct' controller support : PASS LXC: Checking for cgroup 'cpuacct' controller mount-point : FAIL (Mount 'cpuacct' cgroup controller (suggested at /sys/fs/cgroup/cpuacct)) LXC: Checking for cgroup 'devices' controller support : PASS LXC: Checking for cgroup 'devices' controller mount-point : FAIL (Mount 'devices' cgroup controller (suggested at /sys/fs/cgroup/devices)) LXC: Checking for cgroup 'net_cls' controller support : WARN (Enable CONFIG_NET_CLS_CGROUP in kernel Kconfig file) LXC: Checking for cgroup 'freezer' controller support : PASS LXC: Checking for cgroup 'freezer' controller mount-point : WARN (Mount 'freezer' cgroup controller (suggested at /sys/fs/cgroup/freezer))

Thanks in advance, Karthik

edit retag flag offensive close merge delete

Comments

LXC: Checking for cgroup 'memory' controller support : PASS

LXC: Checking for cgroup 'memory' controller mount-point : FAIL (Mount 'memory' cgroup controller (suggested at /sys/fs/cgroup/memory))

KKK gravatar imageKKK ( 2019-09-07 08:41:23 -0500 )edit

The message means that no compute host has the capability (e.g. compatible CPU) or capacity (e.g. disk space) to run this instance.

The Nova scheduler log may have details. If not, set debug logging for Nova and try again.

Does it always happen with all images? Have you ever been able to launch?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-07 19:55:21 -0500 )edit

Addition information to above. I have installed controller and compute node on single server. I have checked the nova-scheduler

KKK gravatar imageKKK ( 2019-09-09 01:50:17 -0500 )edit

Have you checked the scheduler log?

Does it always happen with all images? Have you ever been able to launch an instance?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-09 05:39:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-09-13 10:38:10 -0500

AndyW gravatar image

what flavor are you using and does openstack report you have sufficient resources on your Compute to run the instance (openstack host show YourHost)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-09-07 08:38:09 -0500

Seen: 80 times

Last updated: Sep 13