kolla ansible | not able to connect external network

asked 2019-09-03 08:06:10 -0500

ramadasmr gravatar image

updated 2019-09-04 08:50:21 -0500

I followed https://docs.openstack.org/kolla-ansible/latest/user/quickstart.html (quickstart guide) for all-in-one node installation, i got all the containers up and running and noticed most things working except "network connectivity in external network"

ran init-runonce with below changes EXT_NET_CIDR='192.168.1.0/24' EXT_NET_RANGE='start=192.168.1.211,end=192.168.1.230' EXT_NET_GATEWAY='192.168.1.1'

globals.yml -> http://paste.openstack.org/raw/769977 ovs-vsctl show -> http://paste.openstack.org/raw/769978

i could see instances are able to ping each other , within router namespace i can ping floating IPs assigned to instances but not any LAN IPs.

I have no clue on what to check next, looking for some help.

edit retag flag offensive close merge delete

Comments

It's not clear what your problem is.

i can ping floating IPs assigned to instances but not any LAN IPs

What do you mean by LAN IPs?

Can you access instances via floating IP when you are not in the router namespace?

Can instances reach outside addresses?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-03 22:35:35 -0500 )edit

LAN IPs, any IP in subnet 192.168.1.0/24. Say my desktop which is 192.168.1.2. Yes, I can access instances via floating ip when i do ip nets exec <ns name=""> ssh cirros@<floatingip> No, Instances not able to connect outside address. when i do traceroute 8.8.8.8 last hop is instance floatingip itself

ramadasmr gravatar imageramadasmr ( 2019-09-04 03:48:38 -0500 )edit

You mean that the Kolla host can't access other devices on 192.168.1.0/24? This looks like the wiring to the external network went wrong. Show me the output of ip a.

Can you access floating IPs when you are not in the router namespace?

To what networks are eno1 and eno2 connected?

Bernd Bausch gravatar imageBernd Bausch ( 2019-09-04 05:01:52 -0500 )edit

My bad. No, not able to connect to floating IPs from kolla host when not in router namespace. eno1 and eno2 connected to same switch. Even i was thinking a wiring problem and verified by assigning IP to eno2 and noticed it works.

"ip a" output http://paste.openstack.org/raw/770640

ramadasmr gravatar imageramadasmr ( 2019-09-04 07:07:26 -0500 )edit

any suggestions, please !

ramadasmr gravatar imageramadasmr ( 2019-09-17 08:03:52 -0500 )edit