Ask Your Question
0

openstack instance can not access internet

asked 2019-08-28 12:07:55 -0500

Awais Shah gravatar image

An instance created in the OpenStack can not access the internet. I have created an instance from the ubuntu cloud image.

In the security groups, I allowed all the ports for ingress and egress request of ICMP, TCP and UDP. I can ssh the instance and ping the floating IP of the instance but I can not ping any other IP address. simply the instance can not access the basic internet.

edit retag flag offensive close merge delete

Comments

Do you have a DNS Server in the network (DNS of the ISP), which can be accessed through the VMs?

Raghavan gravatar imageRaghavan ( 2019-08-29 11:15:49 -0500 )edit

Since there is a million ways you can set up OpenStack and its networking, there is also a million possible reasons for your problem.

Narrow it down a little by describing your setup. How did you deploy the cloud, how are instances connected to the outside world, is it an all-in-one setup, ...

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-29 22:22:04 -0500 )edit

I deployed openstack using Devstack and using Nova. I am using the horizon dashboard. The instances are created on the default private network in the openstack and they are connected through a default router with the public network. I can not ping the IPs on public network i.e internet

Awais Shah gravatar imageAwais Shah ( 2019-08-30 04:29:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-08-30 05:06:18 -0500

updated 2019-08-30 05:08:46 -0500

By default, Devstack creates an external network named public. This network is fake - it is not connected to the outside world.

You can configure Devstack for external access. See Locally Accessible Guestson https://docs.openstack.org/devstack/l...

edit flag offensive delete link more

Comments

Wow so in Openstack they have a configuration for PUBLIC_INTERFACE. Do you know a similar configuration for PUBLIC_INTERFACE in multiple nodes? I mean I installed Openstack manually.

Harry996 gravatar imageHarry996 ( 2019-08-30 05:29:49 -0500 )edit

PUBLIC_INTERFACE is a Devstack configuration value, not an OpenStack one. It's a shell variable used in the scripts that set up the Devstack cloud.

There is a guide for setting up a multi-node Devstack: https://docs.openstack.org/devstack/l....

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-30 05:52:26 -0500 )edit

Thanks, I am not a networking guy so having trouble into this. If I add this line into the local.conf file, will it solve my issue? PUBLIC_INTERFACE=eth1

Awais Shah gravatar imageAwais Shah ( 2019-08-30 06:06:24 -0500 )edit

According to the guide, yes if the Devstack host has two NICs and eth1 is connected to the external network. Most likely, that's not your case.

If the Devstack host has a single NIC, see the section Shared Guest Interface.

If you go into OpenStack, you will be forced to learn about networking.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-30 07:10:34 -0500 )edit

Thanks @Bernd. I resolved the issue by simply allocating the floating range and fixed range. FLOATING_RANGE=192.168.1.224/27 FIXED_RANGE=10.11.12.0/24

Awais Shah gravatar imageAwais Shah ( 2019-09-02 10:57:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2019-08-28 12:07:55 -0500

Seen: 731 times

Last updated: Aug 30 '19