HTTPInternalServerError (HTTP 500) still unresolver after going through forum

asked 2014-02-22 05:06:34 -0500

memow gravatar image

updated 2014-02-22 09:22:49 -0500

Jobin gravatar image

Hello,

I seem to have the same error many others, however the fixes did not work for me. I'm following the step-by step guide, made sure to have the same pwd all over just so I don't get confuser, because i'm a first timer. I get this error when I try to create the glance image:

#glance image-create --name="CirrOS 0.3.1" --disk-format=qcow2   --container-format=bare --is-public=true < cirros-0.3.1-x86_64-disk.img

Request returned failure status.

HTTPInternalServerError (HTTP 500)

this is the error I get :

2014-02-22 11:03:15.187 10445 INFO urllib3.connectionpool [-] Starting new HTTP connection (1): controller
2014-02-22 11:03:15.449 10445 INFO glance.registry.client.v1.client [cb079cd9-3e5c-41b5-a04e-10692ba6f645 5a227de8a5234f3c977039926c05a9e2 66a586a1850b4d5bb2e0b5fe7212be3d] Registry client request POST /images raised ServerError

Can you please help ? I'm stuck !

edit retag flag offensive close merge delete

Comments

1

This is info message. There should be Error message in the logs. Can you send the detail error logs ? Is registry server running ?

dheeru gravatar imagedheeru ( 2014-02-22 11:29:42 -0500 )edit

hello sir, yes registry server is running, and these are the only two lines I get when I run the command, in registry.log I get this : 2014-02-22 20:56:45.051 2018 ERROR glance.db.sqlalchemy.api [814db228-4c2f-4f7a-a24d-62f40f45dd13 5a227de8a5234f3c977039926c05a9e2 66a586a1850b4d5bb2e0b5fe7212be3d] Error configuring registry database with supplied sql_connection. Got error: (OperationalError) (2003, "Can't connect to MySQL server on 'controller' (111)") None None

memow gravatar imagememow ( 2014-02-22 15:01:03 -0500 )edit
2

So you have problem in login to db. Please look at the configuration files for db configuration. I can check the configuration files if you copy in paste.openstack.org

dheeru gravatar imagedheeru ( 2014-02-23 01:25:15 -0500 )edit

Please bear with me. this is the bottom part of my glance-api.conf : http://paste.openstack.org/show/68632/ . haven't touched my.conf, should i be granting some particular privileged? I was following the official guide in http://openstack.org for centos and i havent really got to that part

memow gravatar imagememow ( 2014-02-23 05:00:11 -0500 )edit

I just realized I had a problem earlier on here http://paste.openstack.org/show/68641/ Did not see the critical message before ... I granted privileges on glance.* to user glance and on keystone.* to keystone user.. what else?

memow gravatar imagememow ( 2014-02-23 05:21:14 -0500 )edit