Ask Your Question
0

Octavia amphora curl Got a 404 [closed]

asked 2019-08-22 21:05:04 -0500

hanbo gravatar image

[root@controller ~]# nova list --all |grep amphora | faa1a1be-973f-4e16-a818-71deb6d60029 | amphora-db629dab-e739-425b-881a-d67c7b2e68fd | ea5132b92945491289c1ed0674e9024b | ACTIVE | - | Running | lb-mgmt-net=192.168.0.15 |

curl https://192.168.0.15:9443/0.5/info -k {"http_code":404,"error":"404 Not Found: The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again."}

file : /var/log/octavia/worker.log 2019-08-22 21:16:57.497 1963460 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.0.18', port=9443): Max retries exceeded with url: /0.5/info (Caused by NewConnectionError('<urllib3.connection.verifiedhttpsconnection object="" at="" 0x7fb5c40a38d0="">: Failed to establish a new connection: [Errno 111] Connection refused',)) 2019-08-22 21:17:07.511 1963460 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.0.18', port=9443): Max retries exceeded with url: /0.5/info (Caused by NewConnectionError('<urllib3.connection.verifiedhttpsconnection object="" at="" 0x7fb5c40a3f10="">: Failed to establish a new connection: [Errno 111] Connection refused',)) 2019-08-22 21:17:17.529 1963460 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.0.18', port=9443): Max retries exceeded with url: /0.5/info (Caused by NewConnectionError('<urllib3.connection.verifiedhttpsconnection object="" at="" 0x7fb5c40a3cd0="">: Failed to establish a new connection: [Errno 111] Connection refused',)) 2019-08-22 21:17:27.543 1963460 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.0.18', port=9443): Max retries exceeded with url: /0.5/info (Caused by NewConnectionError('<urllib3.connection.verifiedhttpsconnection object="" at="" 0x7fb5c4058390="">: Failed to establish a new connection: [Errno 111] Connection refused',)) 2019-08-22 21:17:37.553 1963460 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.0.18', port=9443): Max retries exceeded with url: /0.5/info (Caused by NewConnectionError('<urllib3.connection.verifiedhttpsconnection object="" at="" 0x7fb5c40a3ad0="">: Failed to establish a new connection: [Errno 111] Connection refused',)) 2019-08-22 21:17:48.823 1963460 DEBUG octavia.amphorae.drivers.haproxy.rest_api_driver [-] Connected to amphora. Response: <response [404]&gt;="" request="" usr="" lib="" python2.7="" site-packages="" octavia="" amphorae="" drivers="" haproxy="" rest_api_driver.py:360="" 2019-08-22="" 21:17:48.823="" 1963460="" debug="" octavia.amphorae.drivers.haproxy.rest_api_driver="" [-]="" got="" a="" 404="" (content-type:="" application="" json)="" --="" connection="" data:="" {"http_code":404,"error":"404="" not="" found:="" the="" requested="" url="" was="" not="" found="" on="" the="" server.="" if="" you="" entered="" the="" url="" manually="" please="" check="" your="" spelling="" and="" try="" again."}="" request="" usr="" lib="" python2.7="" site-packages="" octavia="" amphorae="" drivers="" haproxy="" rest_api_driver.py:370="" 2019-08-22="" 21:17:48.823="" 1963460="" error="" octavia.amphorae.drivers.haproxy.exceptions="" [-]="" amphora="" agent="" returned="" unexpected="" result="" code="" 404="" with="" response="" {u'http_code':="" 404,="" u'error':="" u'404="" not="" found:="" the="" requested="" url="" was="" not="" found="" on="" the="" server.="" if="" you="" entered="" the="" url="" manually="" please="" check="" your="" spelling="" and="" try="" again.'}="" 2019-08-22="" 21:17:48.831="" 1963460="" warning="" octavia.controller.worker.controller_worker="" [-]="" task="" 'standalone-octavia-create-amp-for-lb-subflow-octavia-amp-compute-connectivity-wait'="" (aa262238-445a-46fd-8962-f74d814e55e9)="" transitioned="" into="" state="" 'failure'="" from="" state="" 'running'="" 13="" predecessors ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by hanbo
close date 2019-09-17 00:26:24.437367

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-08-28 12:25:07 -0500

johnsom gravatar image

One thing to note, the "Train" version of the amphora agent now is at version 1.0, so the URL would be https://192.168.0.15:9443/1.0/info There is also now a version discovery document at /.

Aside from that, did you figure out what is causing the amphora agent service to fail? We are not aware of any issues in the amphora-agent at this time.

edit flag offensive delete link more
0

answered 2019-08-23 01:36:09 -0500

hanbo gravatar image

I find ERROR in Amphora VM

[root@amphora-b13947ff-288c-49cf-be52-bb3b4bd69684 ~]# tailf /var/log/messages Aug 23 06:34:19 amphora-b13947ff-288c-49cf-be52-bb3b4bd69684 systemd: Unit amphora-agent.service entered failed state. Aug 23 06:34:19 amphora-b13947ff-288c-49cf-be52-bb3b4bd69684 systemd: am

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-08-22 21:05:04 -0500

Seen: 74 times

Last updated: Aug 28