Ask Your Question
0

Error creating image in glance

asked 2019-08-22 04:21:19 -0500

MOhammad Jalili gravatar image

updated 2019-08-22 04:25:47 -0500

Hi, After installing Glance service in controller node and try to restart the "glance registry service" I get this error:

Failed to restart glance-registry.service: Unit glance-registry.service not found.

And after that when I want to create a test image with the following command:

   # openstack image create "cirros"   --file cirros-0.4.0-x86_64-disk.img   --disk-format qcow2 --container-format bare   --public

I get this error:

Error finding address for http://controller:9292/v2/schemas/image: HTTPConnectionPool(host='controller', port=9292): Max retries exceeded with url: /v2/schemas/image (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7f70902254e0="" at="" object="">: Failed to establish a new connection: [Errno 111] Connection refused',))</urllib3.connection.httpconnection>

What should I do ? Please help.

edit retag flag offensive close merge delete

Comments

Connection refused indicates that Glance is not running. You tried to start the nonexistent Glance Registry, but did you start Glance?

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-22 05:38:17 -0500 )edit

Glance API is up and running $ systemctl status glance-api ● glance-api.service - OpenStack Image Service API Loaded: loaded (/lib/systemd/system/glance-api.service; enabled; vendor preset: enabled) Active: active (running) since Thu 2019-08-22 09:27:31 UTC; 1s ago Main PID: 4203 @Bernd Bausch

MOhammad Jalili gravatar imageMOhammad Jalili ( 2019-08-22 05:54:52 -0500 )edit

Well, you must find out why connections to port 9292 on controller are refused. I would start with curl http://controller:9292.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-22 09:25:38 -0500 )edit

Failed to connect to 10.0.0.101 port 9292: Connection refused. Why do you this it refuses my connection ? @Bernd Bausch

MOhammad Jalili gravatar imageMOhammad Jalili ( 2019-08-25 09:30:41 -0500 )edit

Connection is refused if no process listens on port 9292, IP address 10.0.0.101. My guess: If Glance is running, it is not listening at 10.0.0.101:9292.

Use ss -lntp to check on which TCP ports processes are listening.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-25 10:08:26 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2019-08-23 01:42:55 -0500

neua gravatar image

Hi,

same problem happened for me. Fixed it by removing database, glance packages. Then, try grant permissions to glance user and group for /etc/glance.

Good luck !

edit flag offensive delete link more

Comments

Thank you for replying, but this does not fix my problem.

MOhammad Jalili gravatar imageMOhammad Jalili ( 2019-08-25 09:29:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-08-22 04:21:19 -0500

Seen: 57 times

Last updated: Aug 22