Ask Your Question
0

TASK [keystone : Creating the Keystone service and endpoint] failure

asked 2019-08-06 04:05:32 -0500

vblando gravatar image

updated 2019-08-07 02:17:06 -0500

OS: CentOS 7 Ansible version: 2.8.3 Kolla-Ansible version: 8.0.0

globals.yml

kolla_base_distro: "centos"
kolla_install_type: "source"
openstack_release: "stein"

I already tried redeploying on a fresh installed nodes but this error keeps on happening.

deploy error

TASK [keystone : Creating the Keystone service and endpoint] ****************************************************************************************************************************************
failed: [controller1] (item={u'interface': u'admin', u'url': u'http://172.30.20.250:35357'}) => {"ansible_loop_var": "item", "changed": true, "item": {"interface": "admin", "url": "http://172.30.20.250:35357"}, "msg": "'Traceback (most recent call last):\\n  File \"/tmp/ansible_YVCYGA/ansible_module_kolla_keystone_service.py\", line 58, in main\\n    for _service in cloud.keystone_client.services.list():\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/_legacy_clients.py\", line 95, in keystone_client\\n    self._identity_client\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/openstackcloud.py\", line 616, in _identity_client\\n    \\'identity\\', min_version=2, max_version=\\'3.latest\\')\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/openstackcloud.py\", line 506, in _get_versioned_client\\n    if adapter.get_endpoint():\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/adapter.py\", line 271, in get_endpoint\\n    return self.session.get_endpoint(auth or self.auth, **kwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/session.py\", line 1158, in get_endpoint\\n    return auth.get_endpoint(self, **kwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/identity/base.py\", line 380, in get_endpoint\\n    allow_version_hack=allow_version_hack, **kwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/identity/base.py\", line 271, in get_endpoint_data\\n    service_catalog = self.get_access(session).service_catalog\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/identity/base.py\", line 134, in get_access\\n    self.auth_ref = self.get_auth_ref(session)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py\", line 208, in get_auth_ref\\n    return self._plugin.get_auth_ref(session, **kwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/identity/v3/base.py\", line 178, in get_auth_ref\\n    authenticated=False, log=False, **rkwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/session.py\", line 1064, in post\\n    return self.request(url, \\'POST\\', **kwargs)\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/session.py\", line 903, in request\\n    raise exceptions.from_response(resp, method, url)\\nInternalServerError: Internal Server Error (HTTP 500)\\n'"}
failed: [controller1] (item={u'interface': u'internal', u'url': u'http://172.30.20.250:5000'}) => {"ansible_loop_var": "item", "changed": true, "item": {"interface": "internal", "url": "http://172.30.20.250:5000"}, "msg": "'Traceback (most recent call last):\\n  File \"/tmp/ansible_icI3pI/ansible_module_kolla_keystone_service.py\", line 58, in main\\n    for _service in cloud.keystone_client.services.list():\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/_legacy_clients.py\", line 95, in keystone_client\\n    self._identity_client\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/openstackcloud.py\", line 616, in _identity_client\\n    \\'identity\\', min_version=2, max_version=\\'3.latest\\')\\n  File \"/opt/ansible/lib/python2.7/site-packages/shade/openstackcloud.py\", line 506, in _get_versioned_client\\n    if adapter.get_endpoint():\\n  File \"/opt/ansible/lib/python2.7/site-packages/keystoneauth1/adapter.py\", line 271, in get_endpoint\\n    return self.session.get_endpoint ...
(more)
edit retag flag offensive close merge delete

Comments

This is where I would start:

Please check that your auth_url is correct

Is Keystone running at all? Did it try to run but was killed (check log)? Perhaps due to lack of memory?

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-06 05:17:37 -0500 )edit

I reinstalled the OS of the controller and tried to deploy again, same issue, I have sufficient memory

this is what I go on the logs http://paste.openstack.org/show/755596/

vblando gravatar imagevblando ( 2019-08-06 23:38:03 -0500 )edit

the 3 keystone containers (keystone-fernet, keystone-ssh, keystone) are running fine though, no error on their logs

vblando gravatar imagevblando ( 2019-08-06 23:48:02 -0500 )edit

Most probably Keystone is deployed behind the web server. Can you check if Apache has anything in its log files? The Internal Server Error must come from somewhere. Also check whether the endpoints are reachable now; might have been a glitch while deploying.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-07 02:27:22 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-08-21 11:50:51 -0500

vblando gravatar image

I was able to deploy on a fresh installation, nothing was changed so I don't know where the issue lies. It's running smoothly for a couple of weeks now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-08-06 04:05:32 -0500

Seen: 61 times

Last updated: Aug 21