Ask Your Question
1

No vnc on second compute node

asked 2014-02-20 23:56:22 -0600

Laines gravatar image

updated 2014-02-21 07:43:37 -0600

Jobin gravatar image

Hello
I set up an Openstack Havana environment with this guide: http://docs.openstack.org/havana/inst...

Everything runs smoothly, now I have:
- 1x Controller Node (controller)
- 2x Compute Nodes (compute1, compute2)

The only problem I have is, that vnc in the dashboard is only working with Instances which running on compute1. Instances running on compute2 I get Failed to connect to server (code: 1006).

I already checked the logs but there is nothing at all regarding this. What I noticed is that there is no nova-consoleauth running, at no point in the guide I have to set it up, could this cause the problem?

nova.conf on controller:

[DEFAULT] 
rpc_backend = nova.openstack.common.rpc.impl_qpid
qpid_hostname = controller
auth_strategy = keystone
my_ip = 10.121.33.31
vncserver_listen = 10.121.33.31
vncserver_proxyclient_address = 10.121.33.31

nova.conf on compute1:

[DEFAULT]
auth_strategy = keystone
rpc_backend = nova.openstack.common.rpc.impl_qpid
qpid_hostname = controller
glance_host = controller
network_manager = nova.network.manager.FlatDHCPManager
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_size = 14
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_interface = eth1
flat_network_bridge = br100
public_interface = eth1
my_ip = 10.121.33.32
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.121.33.32
novncproxy_base_url = http://controller:6080/vnc_auto.html

nova.conf on compute2:

[DEFAULT]
auth_strategy = keystone
rpc_backend = nova.openstack.common.rpc.impl_qpid
qpid_hostname = controller
glance_host = controller
network_manager = nova.network.manager.FlatDHCPManager
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_size = 14
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_interface = eth1
flat_network_bridge = br100
public_interface = eth1
my_ip = 10.121.33.33
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.121.33.33
novncproxy_base_url = http://controller:6080/vnc_auto.html
edit retag flag offensive close merge delete

Comments

Try controller IP instead of 'controller'?

Eric Xie gravatar imageEric Xie ( 2014-09-18 02:17:18 -0600 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-16 04:28:15 -0600

Qiang gravatar image

updated 2014-09-17 22:35:00 -0600

I am facing the same problem, the VNC is working for the first compute node(10.11.21.34),but it is not working for the second compute node(10.11.21.37)

On controller(10.11.21.33) /etc/nova/nova.conf:

#
vnc_enabled = True
vncserver_host = 0.0.0.0
vncserver_listen = 10.11.21.33
vncproxy_url = http://10.11.21.33:6080
vncserver_proxyclient_address = 10.11.21.33
novncproxy_base_url=http://10.11.21.33:6080/vnc_auto.html
#

On compute-vmware(10.11.21.34) /etc/nova/nova.conf, compute-vmware is connecting to Vmware vCenter:

#
vnc_enabled = True
vncserver_listen = 10.11.21.34
vncserver_proxyclient_address = 10.11.21.34
vncproxy_url = http://10.11.21.33:6080
novncproxy_base_url=http://10.11.21.33:6080/vnc_auto.html
#

On compute-xen(10.11.21.37) /etc/nova/nova.conf, compute-xen is connecting to Xenserver 6.2:

#
vnc_enabled = True
vncserver_listen = 10.11.21.37
vncserver_proxyclient_address = 10.11.21.37
vncproxy_url = http://10.11.21.33:6080
novncproxy_base_url=http://10.11.21.33:6080/vnc_auto.html
#

Anyone can help ? Thanks.

edit flag offensive delete link more
0

answered 2014-02-21 06:45:45 -0600

SamYaple gravatar image

On the second compute node, verify you are listening on port 6080

If you are not listening on the port, check if you have installed the nova novnc package on the second compute node.

edit flag offensive delete link more

Comments

I have installed the nova novnc package on the second compute node,but it is not working either. Any solution ?

Qiang gravatar imageQiang ( 2014-09-16 04:29:36 -0600 )edit
0

answered 2014-02-23 04:39:35 -0600

Govardhan gravatar image

updated 2014-02-24 08:24:07 -0600

use the following configuration in nova.conf file

controller :

vnc_enabled = True
vncserver_host = 0.0.0.0
vncserver_listen = < controller ip >
vncproxy_url = http://<controller ip>:6080
vncserver_proxyclient_address = <controller ip>
novncproxy_base_url=http://<controller ip>:6080/vnc_auto.html

compute node:

vnc_enabled = True
vncserver_listen = <compute ip>
vncserver_proxyclient_address = <compute ip>
vncproxy_url = http://<controller ip>:6080
novncproxy_base_url=http://<controller ip>:6080/vnc_auto.html

I also have faced the same problem. The above cofiguration solved my issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-02-20 23:56:22 -0600

Seen: 1,713 times

Last updated: Sep 17 '14