Ask Your Question
0

NoValidHost_Remote: No valid host was found

asked 2019-07-24 08:00:45 -0500

anonymous user

Anonymous

updated 2019-07-26 04:23:08 -0500

Hi Guys,

I hope anyone can help:-) I have Openstack RDO (Queens) installed on one virtual controller and 2 nodes. Until now I do not have a shared Storage but will be installed/configured soon:-) There is only a local storage of 225GB available.

Cirros VMs with small flavors i can launch. If i take an appliance image with 80GB disk and 8GB RAM it fails immediately with the error:

2019-07-19 16:21:45.360 9848 WARNING nova.scheduler.utils [req-f52bfde6-11ae-4b76-bb8c-2f8fc779ae4d 16d578b78ded4a6dbf0300dcb9e3c475 14bfa59ab01c4cc8bc5bd9028e160ab0 - default default] [instance: 532081d9-61cd-4eda-976e-487effc3c076] Setting instance to ERROR state.: NoValidHost_Remote: No valid host was found. 
2019-07-23 10:16:19.276 9852 ERROR nova.conductor.manager [req-b2981387-b0c4-46a6-8a63-8369b32699ec 16d578b78ded4a6dbf0300dcb9e3c475 14bfa59ab01c4cc8bc5bd9028e160ab0 - default default] Failed to schedule instances: NoValidHost_Remote: No valid host was found. There are not enough hosts available.

Some checks:

openstack hypervisor list = state is up for controller and the 2 nodes

openstack hypervisor show (controller) = http://paste.openstack.org/show/754798/

openstack hypervisor show (node1) = http://paste.openstack.org/show/754799/

openstack hypervisor show (node2) = http://paste.openstack.org/show/754801/

openstack hypervisor stats show = http://paste.openstack.org/show/754802/

openstack compute service list = everything enabled and up

openstack configuration show: http://paste.openstack.org/show/754795/

openstack flavor list = all true, tiny, small, medium, large, xlarge

openstack flavor show large = http://paste.openstack.org/show/754796/

openstack host list = conductor (internal), scheduler (internal), consoleauth (internal), compute (nova), compute (nova), compute (nova, console (internal) ===> one of the nodes is also the controller.

openstack show host (controller) = http://paste.openstack.org/show/754797/

I appreciate any help on this :-)

thx a lot

edit retag flag offensive close merge delete

Comments

The nova scheduler log should tell you the reason why no suitable host was found.

The term RDO is ambiguous. How did you deploy the cloud? Packstack, Tripleo or manual deployment?

Bernd Bausch gravatar imageBernd Bausch ( 2019-07-24 09:10:38 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2019-07-25 03:37:18 -0500

GoOpenstack79 gravatar image

the problem was that the nova instances directory was located on the local root filesystem which has only 50GB :-) I changed that to another filesystem with more space.

Thx for answering:-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-07-24 08:00:45 -0500

Seen: 51 times

Last updated: Jul 26