Ask Your Question
0

Neutron external network namespace unable to route to 192.168.0.1 or 8.8.8.8

asked 2014-02-20 13:49:35 -0500

tzakrajs gravatar image

updated 2014-02-20 17:15:50 -0500

I have a controller node, network node and compute node all connected to a VirtualBox Bridge Network (192.168.0.0/24 subnet). Additionally, they are connected to a management network 10.0.0.0/24. The compute and network nodes are also additionally connected over a data network (for GRE) 10.1.0.0/24.

The nodes with 192.168.0.0/24 addresses can ping eachother just fine as well as 192.168.0.0/24 addresses inside the br-ex (the external bridge). The problem is that nothing behind br-ex can route to 192.168.0.1, and thus instances cannot get to the internet (8.8.8.8). The nova instances cannot ping any 192.168.0.0/24 address that isn't connected to the VirtualBox bridge or the openvswitch external bridge. Private nova instance gateway 10.5.5.1 is properly routing to 192.168.0.0/24, but again, not beyond the VirtualBox bridge (to the D-Link Router).

Details here: http://paste.openstack.org/show/67547/

Was I incorrect to use 192.168.0.0/24 as my ext-net cidr since I am relying on an upstream router with the same subnet to route packets to the internet?

Example of bad behavior, from inside vm:

$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
^C
--- 192.168.0.1 ping statistics ---
169 packets transmitted, 0 packets received, 100% packet loss

and then from the external gateway interface connected to the br-ex bridge

root@network-1:~# ip netns exec qrouter-45389376-b5b2-4032-8203-ed82cc870ea1 tcpdump -nei qg-c947b62d-8f
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on qg-c947b62d-8f, link-type EN10MB (Ethernet), capture size 65535 bytes
15:11:17.553904 fa:16:3e:af:cf:f6 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: Request who-has 192.168.0.1 tell 192.168.0.50, length 28
15:11:18.550822 fa:16:3e:af:cf:f6 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: Request who-has 192.168.0.1 tell 192.168.0.50, length 28
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-02-21 22:59:23 -0500

tzakrajs gravatar image

I have worked around this by setting up a nat gateway on 192.168.0.30 and using it as the default gateway for the qrouter namespace.

edit flag offensive delete link more

Comments

how do you do that exactly? i have a similar issue i think

n7rxDE gravatar imagen7rxDE ( 2014-08-27 04:01:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-02-20 13:49:35 -0500

Seen: 1,990 times

Last updated: Feb 21 '14