Cant access my instance (ping/ssh)

asked 2019-07-04 12:56:55 -0500

Kilmer Luiz gravatar image

I have installed a RDO Packstack at a CentOS without any specific settings, just followed the tutorial from RDO webpage. Im using Stein.

What i've already done:

  • updated default Security Group so it enables all TCP and ICMP ports;
  • created a public network and subnet with my local settings (164.xxx.xxx);
  • created a private network and subnet with openstack "public network" settings (172.24.4.0/24);
  • created a router to connect public and private networks;
  • created a new instance at private network;
  • added new Floating IP (from public) and associated it with that instance.

I also tried connecting that.What am I missing?

I tried connecting with SSH, pem file, ping but nothing works. If I ping, I get a "destination host unreachable".

I think the problem may be related to the creation of the public network. As a admin (in Horizon), I created a flat network and when setting "Physical Network", I'm not sure on what to set. I tried "enp3s0", which is my psysical device. I think it may be something wrong at some neutron file, like physical_interface_mappings at linuxbridge_agent.ini. But I do not have this file anywhere, and I couldn't find that flag as well. Is there some related file? Why I cant access my instances from others machines from the same host network (164.xxx.xxx network)?

edit retag flag offensive close merge delete

Comments

created a private network with "public network" settings

That doesn’t make sense to me. 172.24.4.0\24 is Packstack’s default external subnet.

By default, Packstack Stein deploys OVN, not Linuxbridge. There must be an agent config file for OVN, which contains the definition for the physical NW.

Bernd Bausch gravatar imageBernd Bausch ( 2019-07-04 18:36:27 -0500 )edit

For a Stein Packstack deployment with Openvswitch (not OVN), which maps the external network to the existing physical network, see https://ask.openstack.org/en/question....

Bernd Bausch gravatar imageBernd Bausch ( 2019-07-04 18:39:34 -0500 )edit

I also tried setting 10.0.0.0/24 for private network instead of 172.24.4.0/24, and also did not worked. Does that sould not work as well?

I'll try the other instalation, from that question.

Kilmer Luiz gravatar imageKilmer Luiz ( 2019-07-05 11:43:48 -0500 )edit

I believe that your external network was not set up correctly.

Bernd Bausch gravatar imageBernd Bausch ( 2019-07-05 15:18:31 -0500 )edit