Ask Your Question
0

fatal: unable to access 'https://git.openstack.org/openstack-dev/devstack/': Could not resolve host: git.openstack.org

asked 2019-06-28 02:53:57 -0500

Eddie gravatar image

Well, I am new to OpenStack and Ubuntu.. I am trying to git clone https://git.openstack.org/openstack-dev/devstack (https://git.openstack.org/openstack-d...) to install devstack but only result I get is this error.... heres is my network settings:

stack@eja:~$ route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default _gateway 0.0.0.0 UG 0 0 0 enp0s8 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 enp0s8 192.168.56.0 0.0.0.0 255.255.255.0 U 0 0 0 enp0s3 stack@eja:~$ ip route default via 192.168.0.1 dev enp0s8 192.168.0.0/24 dev enp0s8 proto kernel scope link src 192.168.0.22 192.168.56.0/24 dev enp0s3 proto kernel scope link src 192.168.56.103 stack@eja:~$ ifconfig enp0s3: flags=4163<up,broadcast,running,multicast> mtu 1500 inet 192.168.56.103 netmask 255.255.255.0 broadcast 192.168.56.255 inet6 fe80::a00:27ff:fe9f:ad56 prefixlen 64 scopeid 0x20<link> ether 08:00:27:9f:ad:56 txqueuelen 1000 (Ethernet) RX packets 16049 bytes 1453558 (1.4 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 10732 bytes 1717177 (1.7 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

enp0s8: flags=4163<up,broadcast,running,multicast> mtu 1500 inet 192.168.0.22 netmask 255.255.255.0 broadcast 192.168.0.255 inet6 fe80::a00:27ff:fead:688c prefixlen 64 scopeid 0x20<link> ether 08:00:27:ad:68:8c txqueuelen 1000 (Ethernet) RX packets 374 bytes 26050 (26.0 KB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 184 bytes 33740 (33.7 KB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<up,loopback,running> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Local Loopback) RX packets 23420 bytes 1697476 (1.6 MB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 23420 bytes 1697476 (1.6 MB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Thank you for your help

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-06-28 06:50:13 -0500

This looks like a problem with name resolution on your machine. It's saying it can't find the name "git.openstack.org" in DNS, but it's resolving for me with no problem. Do you have trouble cloning Git repositories from anywhere else? You could try git clone https://opendev.org/openstack/devstack instead, for example (the URL you've been trying is an old redirect maintained for compatibility with the previous place that repository was hosted).

edit flag offensive delete link more

Comments

I have tried couple of git repositories including your recommended URL but still having same issue.. is there anything else I should try?? Thanks for your help

Eddie gravatar imageEddie ( 2019-06-30 08:29:31 -0500 )edit

works for me. Can you access openstack.org or opendev.org at all?

Bernd Bausch gravatar imageBernd Bausch ( 2019-07-01 03:30:37 -0500 )edit

Do you use this machine for anything else? It really sounds like you haven't configured any DNS resolvers for it yet, or have set it to use resolvers you're unable to reach. How you configure your machine for DNS resolution will vary depending on your operating system and how it does network config.

fungi gravatar imagefungi ( 2019-07-01 07:00:00 -0500 )edit

It appeared to be dns problem. I rebooted the machine and now it works. Thank you for your hepl

Eddie gravatar imageEddie ( 2019-07-02 02:24:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-06-28 02:53:57 -0500

Seen: 57 times

Last updated: Jun 28