Ask Your Question
0

No credentials specified for placement API in nova.conf

asked 2019-06-26 12:19:45 -0500

ZCTZ gravatar image

updated 2019-06-27 08:05:01 -0500

Hello, I was following these instructions on setting up Nova:

https://docs.openstack.org/nova/latest/install/verify.html (https://docs.openstack.org/nova/lates...)

When I run:

nova-status upgrade check

It says:

+-------------------------------------------------------------------+ | Upgrade Check Results | +-------------------------------------------------------------------+ | Check: Cells v2 | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Placement API | | Result: Failure | | Details: No credentials specified for placement API in nova.conf. | +-------------------------------------------------------------------+ | Check: Ironic Flavor Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Request Spec Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Console Auths | | Result: Success | | Details: None | +-------------------------------------------------------------------+

In nova.conf on both the controller and the compute node I have [placement] configured. Does anyone know WHAT EXACTLY that error is telling me to do? this has been driving me a bit crazy.

Details: No credentials specified for placement API in nova.conf.

thanks

Update:

Is that message talking about the configuration on the controller node or the compute node?

Also in /etc/nova/nova.conf on the controller node I have:

[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
user_domain_name = Default
password = removedbutdoesntmatteranyway
username = placement
auth_url = http://controller:5000/v3
auth_type = password

In /etc/placement/placement.conf on the controller node I have:

auth_strategy = keystone

[keystone_authtoken]
auth_url = http://controller:5000/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = Default
user_domain_name = Default
project_name = service
username = placement
password = removedbutdoesntmatteranyway

anyone know what else I can check or look at???

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2019-06-27 04:32:54 -0500

cdent gravatar image

While it's true, as Eranachandran says, that you need to configure the placement service itself using a placement.conf you still need to configured a [placement] section in nova.conf so that the compute and controller nodes know how to access and authenticate to the placement service. See the [placement]part of the instructions at https://docs.openstack.org/nova/stein/install/compute-install-ubuntu.html#install-and-configure-components (https://docs.openstack.org/nova/stein...) (near the end of that section).

If you've already got that section, and the credentials in it are correct, then you may have issues with your Keystone service.

edit flag offensive delete link more

Comments

I added info to the post any more advice is appreciated.

ZCTZ gravatar imageZCTZ ( 2019-06-27 08:05:25 -0500 )edit
0

answered 2019-06-27 00:30:11 -0500

Hai ZCTZ,

Your Installing Stein Version of OpenStack. From Stein version of OpenStack, the placement Service need to be configured using placement.conf file(/etc/placement/placement.conf). Configure Placement service using the following documentation,

https://docs.openstack.org/placement/...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-06-26 12:19:45 -0500

Seen: 51 times

Last updated: Jun 27