keystone token issue error (http 401) [closed]

asked 2019-06-23 02:17:05 -0500

Jillman gravatar image

I have install a openstack liberty on CentOS 7.0 . I am using official documentation for step by step installtion , and I can login by admin_token

But affter I excute the verify command

openstack --os-auth-url http://node1:35357/v3 \ --os-project-domain-id default --os-user-domain-id default \ --os-project-name admin --os-username admin --os-auth-type password \ token issue

I got an error message "The request you have made requires authentication. (HTTP 401)" And I find the error log is Could not find domain: default.

I check my keystone configuration like bellow

+----------------------------------+---------+---------+-------------+

| ID | Name | Enabled | Description |

+----------------------------------+---------+---------+-------------+

| 3aafd66459af4ea6904712395baf9fda | default | True | |

| f225d2656c704f69b05fafdd671e5575 | new | True | |

+----------------------------------+---------+---------+-------------+

[root@node1 ~]# openstack project show admin

+-------------+----------------------------------+

| Field | Value |

+-------------+----------------------------------+

| description | Admin Project |

| domain_id | 3aafd66459af4ea6904712395baf9fda |

| enabled | True |

| id | ceaa125f7e384423988189df51d30cc0 |

| is_domain | False |

| name | admin |

| parent_id | 3aafd66459af4ea6904712395baf9fda |

+-------------+----------------------------------+

[root@node1 ~]# openstack user show admin

+---------------------+----------------------------------+

| Field | Value |

+---------------------+----------------------------------+

| domain_id | 3aafd66459af4ea6904712395baf9fda |

| enabled | True |

| id | f410c347a20a47d58ef2b0dd67841efb |

| name | admin |

| options | {} |

| password_expires_at | None |

+---------------------+----------------------------------+

I also tried to use localhost instead of node1 、 use Default instead if default 、even I tried to creat a new domain or install openstack on CentOS 7.6 . But I have the same error .

Is I make something wrong ? Could anyone help me to resolve my problem ?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Jillman
close date 2019-07-03 00:21:55.837898

Comments

First: Why do you install such an old release? There is no support for it anymore. It is hard to find the source code. Hard or impossible to double-check your results.

Bernd Bausch gravatar imageBernd Bausch ( 2019-06-23 08:44:14 -0500 )edit

Normally, you should have a domain named Default with ID default. However, the ID of your Default domain seems to be 3aafd... This is why --os-project-domain-id default and --os-user-domain-id default don't work. Replace default with 3aafd66459af4ea6904712395baf9fda.

Bernd Bausch gravatar imageBernd Bausch ( 2019-06-23 08:46:15 -0500 )edit

thank you for your advise I solved the problem through install the stein version

Jillman gravatar imageJillman ( 2019-07-03 00:21:42 -0500 )edit