Ask Your Question
0

Linuxbridge physical interfaces not appearing in brctl show

asked 2019-06-19 14:58:14 -0500

Samerious gravatar image

updated 2019-06-19 16:23:28 -0500

I'm having an issue were it looks like the linuxbridge is not configured with the physical interface. This is causing an issue sshing/pinging my instance.

root@prod-openstack-controller1:~# brctl show
bridge name     bridge id               STP enabled     interfaces
brq319e7153-80          8000.928506805356       no              tap0965586e-88
consul0         8000.000000000000       no
virbr0          8000.525400542811       yes             virbr0-nic

have configuration in linuxbridge_agent.ini to assign the networks to the interfaces

physical_interface_mappings = public:ens192,private:ens224

Is Openstack supposed to auto detect the interfaces? How can I troubleshoot this issue?

edit retag flag offensive close merge delete

Comments

1

Have you checked neutron logs for any hints? What do your configs look like, especially in /etc/neutron/plugins/ml2/ml2_conf.ini the value for mechanism_drivers?

eblock gravatar imageeblock ( 2019-06-20 09:11:05 -0500 )edit

Failed reporting state!: MessagingTimeout: Timed out waiting for a reply to message ID fb0447cd1c4a4100970812b79647a69c

mechanism_drivers = linuxbridge

The above error message is from linuxbridge log. I don't think the messaging agent is causing a bridge issue though.

Samerious gravatar imageSamerious ( 2019-06-20 11:14:15 -0500 )edit

I don't see any error message in your question, could you update it then?

eblock gravatar imageeblock ( 2019-06-21 02:14:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-06-26 11:23:54 -0500

Samerious gravatar image

After I followed the guide at https://docs.openstack.org/install-guide/launch-instance-networks-provider.html (https://docs.openstack.org/install-gu...) the interfaces started to show up in brctl show.

Originally I had created the networks through the Horizon Web UI and the networks I had configured in ml2_conf.ini and linuxbridge_agent.ini, were not assigned to the networks that were created through the webui.

I discovered this by running openstack network list openstack network show ID

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-06-19 14:58:14 -0500

Seen: 41 times

Last updated: Jun 19