How do I change change default_panel in horizon?

asked 2019-06-19 09:16:44 -0500

runamuck gravatar image

I just deployed OpenStack Rocky.

When I open the horizon dashboard and navigate to any project, it defaults to "Workbooks" and then emits an error.

I would like to set the default_panel to instances.

I followed the https://docs.openstack.org/horizon/latest/configuration/customizing.html (customization instructions) and added the following to /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py

import os

from django.utils.translation import ugettext_lazy as _

from horizon.utils import secret_key

from openstack_dashboard import exceptions
from openstack_dashboard.settings import HORIZON_CONFIG

## I added this to top of the file
from horizon import get_panel
##

DEBUG = False
TEMPLATE_DEBUG = DEBUG

<snip>

#DISALLOW_IFRAME_EMBED = True

HORIZON_CONFIG["disallow_iframe_embed"] = True

## I added this to the end of the file
project = get_dashboard("project")
project.default_panel = "instances"
##

I then navigated to the horizon GUI, logged in and it still defaults to "workbooks."

Did I configure this correctly? Do I need to re-start the horizon service for the change to take effect?

edit retag flag offensive close merge delete