Failed to bind port neutron.plugins.ml2.managers

asked 2019-06-15 10:10:34 -0500

zxslm gravatar image

updated 2019-06-21 02:28:59 -0500

eblock gravatar image

Hi, I am using openstack 3.18.0. I got below error when I create a instance with below command. By the way, I am using the KVM as the default hypervisor.

openstack server create --flavor m1.tiny --image CirrOS01 --nic net-id=a9c54782-2c31-4688-be1b-8e9e0491311a --security-group default --key-name test_key eno1-instance

2019-06-15 04:26:52.116 110813 ERROR neutron.plugins.ml2.managers [req-d8da56fb-b7ff-4df2-af4c-4b68fb26d1dd 0937edfa9b784194b7cb47fb5bf65eaa 966c28f276424b35ba37956832bb12d6 - default default] Failed to bind port c26922b8-c82e-441a-a0c6-ec4056962e77 on host http://openstack.safelle.com for vnic_type normal using segments [{'network_id': 'a9c54782-2c31-4688-be1b-8e9e0491311a', 'segmentation_id': None, 'physical_network': u'eno1', 'id': '9fc06cf1-c282-4a48-905c-653b6e285080', 'network_type': u'flat'}]

here are the commands I use to create the network.

neutron net-create --shared --provider:physical_network eno1 --provider:network_type flat eno1

neutron subnet-create --name eno1 --allocation-pool start=192.168.20.50,end=192.168.20.100 --dns-nameserver 61.134.1.5 --gateway 192.168.20.254 eno1 192.168.20.0/24

/etc/neutron/plugins/ml2/ml2_conf.ini

[DEFAULT]
[ml2]
type_drivers=geneve,flat
tenant_network_types=geneve
mechanism_drivers=ovn
path_mtu=0
extension_drivers=port_security,qos

[securitygroup]
enable_security_group=True
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ml2_type_geneve]
max_header_size=38
vni_ranges=10:100

[ml2_type_flat]
flat_networks=eno1

[ovn]
ovn_nb_connection=tcp:192.168.20.2:6641
ovn_sb_connection=tcp:192.168.20.2:6642
ovn_metadata_enabled=True
edit retag flag offensive close merge delete

Comments

I reformatted your question to make it more readable. Please use code tags when pasting config files or error messages.

eblock gravatar imageeblock ( 2019-06-21 02:19:57 -0500 )edit

Could you please provide the output of openstack port show -c id -c project_id c26922b8-c82e-441a-a0c6-ec4056962e77? Is that the same project_id where you try to create the instance in?

eblock gravatar imageeblock ( 2019-06-21 02:32:42 -0500 )edit

Thanks eblock for you input. Actually, I destroy the environment after several tries to fix. I will try your suggestion next time when I met the similar issue.

zxslm gravatar imagezxslm ( 2019-06-21 20:41:41 -0500 )edit