Unable to ping newly launch instance

asked 2019-06-06 03:20:28 -0500

arup_thakuria gravatar image

Hi Team I have created an external shared network.

neutron net-create public01 --provider:network_type flat --provider:physical_network physnet1 --router:external=True --shared associated the sub net with the created network.

neutron subnet-create --name public_subnet --enable_dhcp=False --allocation_pool start=192.168.8.90,end=192.168.8.95 --gateway=192.168.8.1 public01 192.168.8.0/24

Please note that the above address range is from my host machine network where I have created the VM & install openstack.

After that i launched an instance with a modified security group for which ping & ssh are allowed.

Then generate floating IP from the above created external network "public01"

Same has been associated with the instance but the instance is not pinging from the host machine.

Bridge integration is also done. Kindly suggest.

edit retag flag offensive close merge delete

Comments

Please share how you configured the mapping of physnet1. Check if the instance has received its fixed IP address from DHCP. Check if you can reach the instance's fixed IP address from the DHCP namespace.

Bernd Bausch gravatar imageBernd Bausch ( 2019-06-06 07:51:42 -0500 )edit

mapping of physnet1

file-----/etc/neutron/plugins/ml2/openvswitch_agent.ini

bridge_mappings =

bridge_mappings=physnet1:br-ex yes it received the fixed ip 2ff78006-0ea5-4a1c-be02-45658f118a55 | arup-instance | ACTIVE | - | Running | public01=192.168.8.93

arup_thakuria gravatar imagearup_thakuria ( 2019-06-06 09:26:01 -0500 )edit

[root@RDOSERVER ml2(keystone_arup)]# ip netns qrouter-218227f7-39c3-4735-8fb4-8650f5fa7d82 (id: 1) qdhcp-d014c39e-9a93-46ce-8f00-997220dbe1a1 (id: 0) [root@RDOSERVER ml2(keystone_arup)]# ip netns exec qdhcp-d014c39e-9a93-46ce-8f00-997220dbe1a1 Not rechable from dhcp name space

arup_thakuria gravatar imagearup_thakuria ( 2019-06-06 09:27:26 -0500 )edit

I guess it did not receive the IP address. You can confirm that with the instance’s console log.

It could be that the DHCP service doesn’t work or that there is no connectivity between DHCP server and instance. Check if the Neutron services are up.

How did you deploy this cloud?

Bernd Bausch gravatar imageBernd Bausch ( 2019-06-06 17:16:39 -0500 )edit

Please note that I created that external network with option --enable_dhcp=False,instead I assign pools of IP address,when I launched the instance it used to get the ip from that pool which can be confirmed from the nova list command & yes i have checked from the nova console-log also,instance is up

arup_thakuria gravatar imagearup_thakuria ( 2019-06-06 22:09:32 -0500 )edit