Spice: Nothing matches URI

asked 2019-05-30 13:05:28 -0500

cnkunz gravatar image

Hey everyone, I'm trying to switch from noVNC to Spice in order to see if it will fix the pipe character (|) not entering correctly. I've been trying to setup the Spice console but i'm getting a 404 error saying that nothing matches the URI when I attempt to view the console through horizon. I'm running ubuntu 16.04 on controller and compute, and Queens Openstack. I have nova-spiceproxy installed and the service is running. The queens documentation for Spice is all of a paragraph long and states that nova-spicehtml5proxy service talks directly to the hypervisor; however, I do not have that service on my machine nor can I install it (unable to locate package). Any help towards getting spice to work and/or a workaround or fix to the pipe issue would be great, thanks!

On my controller node:

[DEFAULT]

web = /usr/share/spice-html5

[vnc]

enabled = false

[spice]

enabled = True

agent_enabled = True html5proxy_base_url = http://controller1m:6082/spice_auto.html

server_listen = 192.168.55.30

server_proxyclient_address = 192.168.55.30

keymap = en-us

html5proxy_host = 0.0.0.0

html5proxy_port = 6082

edit retag flag offensive close merge delete