Stein: keystone doesn't use 35357, while heat doc still uses it [closed]

asked 2019-05-27 22:09:05 -0600

mystic gravatar image

heat.log

2019-05-23 16:19:40.757 23915 WARNING keystoneauth.identity.generic.base [-] Failed to discover available identity 
versions when contacting http://controller:35357. Attempting to parse version from URL.: ConnectFailure: 
Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): 
Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 
0x7fc78b9d0f50>: Failed to establish a new connection: [Errno 111] ECONNREFUSED',))

After I change all 35357 on heat.conf to 5000, creating stack works well.
Quoted from stein keystone documentation.

Note
Before the Queens release, keystone needed to be run on two separate ports to accommodate the Identity v2 API which ran a separate admin-only service commonly on port 35357. With the removal of the v2 API, keystone can be run on the same port for all interfaces.

https://docs.openstack.org/keystone/stein/install/keystone-install-rdo.html (keystone installation)
https://docs.openstack.org/heat/stein/install/install-rdo.html (heat installation)
Maybe we should update heat doc that all 35357 should be replaced by 5000.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by mystic
close date 2019-05-28 20:20:40.404136

Comments

Can you use the bug icon on the Heat documentation page to file a bug?

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-28 00:50:41 -0600 )edit

Hi, @Bernd Bausch
I have already reported a bug about heat documentation.
https://storyboard.openstack.org/#!/story/2005784 (Here)

mystic gravatar imagemystic ( 2019-05-28 02:20:04 -0600 )edit