Ask Your Question
0

Wrong Keystone os_auth_url being used for Stein nova client calls [closed]

asked 2019-05-14 09:17:00 -0500

Pat gravatar image

updated 2019-05-14 10:54:50 -0500

Installed Stein controller/ compute
CentOS 7.6

Everything but Nova Client calls working. So I am seeing this in nova-api.log

openstack server list

==> nova-api.log <==

2019-05-14 15:02:27.899 22856 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Unable to establish connection to http://127.0.0.1:35357: HTTPConnectionPool(host='127.0.0.1', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7f394e3855d0="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)): ConnectFailure: Unable to establish connection to http://127.0.0.1:35357: HTTPConnectionPool(host='127.0.0.1', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.httpconnection 0x7f394e3855d0="" at="" object="">: Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) 2019-05-14 15:02:27.901 22856 INFO nova.osapi_compute.wsgi.server [-] 192.168.128.181 "GET /v2.1/servers/detail HTTP/1.1" status: 503 len: 498 time: 0.0042300</urllib3.connection.httpconnection></urllib3.connection.httpconnection>

I have no idea where it is getting this endpoint from http://127.0.0.1:35357 ?

Port 35357 has been deprecated. Anyone any idea what I've missed? I've pretty much grepped the file system for 35357, without discovering where this is coming from.

env | grep OS
OS_PROJECT_DOMAIN_ID=default
OS_REGION_NAME=RegionOne
OS_USER_DOMAIN_NAME=Default
OS_PROJECT_NAME=admin
OS_IDENTITY_API_VERSION=3
OS_PASSWORD=admin
OS_AUTH_URL=http://controller:5000/v3
OS_USERNAME=admin
OS_INTERFACE=public
OS_PROJECT_DOMAIN_NAME=Default

Same error when using Horizon

/etc/openstack-dashboard/local_settings

OPENSTACK_HOST = "controller"
OPENSTACK_KEYSTONE_URL = "http://%s:5000/v3" % OPENSTACK_HOST

cat /etc/hosts

192.168.128.181 controller

nova.conf (re-edited to chow my mistake) > [keystone]
auth_url = http://controller:5000/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = nova
[keystone_authtoken]
[libvirt]

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Bernd Bausch
close date 2019-05-15 07:35:38.704203

Comments

Most likely the incorrect Keystone endpoint is in nova.conf.

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-14 09:45:40 -0500 )edit

Hi Bernd. Thanks for the suggestion. The nova.conf is configured fairly basically but I'm wondering if there is something missing in it that causes this endpoint url to default in somehow.

I'll update the main question with it, if I can.

Pat gravatar imagePat ( 2019-05-14 10:23:39 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2019-05-14 10:46:32 -0500

[keystone_authtoken] is empty. This can’t be correct and is a likely candidate for the root cause of your problem.

edit flag offensive delete link more
0

answered 2019-05-14 11:00:25 -0500

Pat gravatar image

Yup that was it. Missing all configs from [keystone_authtoken]

Thanks Bernd

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-14 09:17:00 -0500

Seen: 23 times

Last updated: May 14