Ask Your Question
0

Unable to Access Openstack DashBoard.

asked 2019-05-14 08:48:24 -0500

Murali Stack gravatar image

Hi everyone,

After following the OpenStack liberty Install guide, i'm now in the step of trying to access the dashboard for the first time but every time i try to access horizon this message shows up:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Error Logs of Apache2 :

root@controller:~# tail -f /var/log/apache2/error.log [Tue May 14 19:11:26.223440 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] File "/usr/lib/python2.7/dist-packages/django/conf/__init__.py", line 110, in __init__ [Tue May 14 19:11:26.223468 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] mod = importlib.import_module(self.SETTINGS_MODULE) [Tue May 14 19:11:26.223502 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module [Tue May 14 19:11:26.223580 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] __import__(name) [Tue May 14 19:11:26.223667 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] File "/usr/share/openstack-dashboard/openstack_dashboard/settings.py", line 381, in <module> [Tue May 14 19:11:26.224067 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] from local.local_settings import * # noqa: F403,H303 [Tue May 14 19:11:26.224256 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] File "/usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py", line 325 [Tue May 14 19:11:26.224271 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] ... [Tue May 14 19:11:26.224281 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] ^ [Tue May 14 19:11:26.224291 2019] [wsgi:error] [pid 5219:tid 139939861927680] [remote 10.0.0.1:57837] SyntaxError: invalid syntax

can someone please help me on this?

Apache/2.4.7 (Ubuntu) Server at 172.19.11.116 Port 80

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-05-14 09:43:09 -0500

updated 2019-05-14 09:43:40 -0500

Don't use the Liberty install guide, it's not compatible with recent OpenStack releases. The most recent install guide is at http://docs.openstack.org/install-guide/.

edit flag offensive delete link more
0

answered 2019-05-14 09:59:04 -0500

Spoorthi Vaidya gravatar image

As Bernd said, don't use older version of OpenStack. Use latest versions. You will face many issues if you try to install older releases.

Even once i had the same issue,

In the file /etc/httpd/conf.d/openstack-dashboard.conf , I added the line:

WSGIApplicationGroup %{GLOBAL}

In the file /etc/nova/nova.conf , make sure you have added below lines.

[DEFAULT]

enabled_apis = osapi_compute,metadata

and problem got solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-14 08:48:24 -0500

Seen: 20 times

Last updated: May 14