Ask Your Question
0

kolla-ansible/tools/init-runonce failed (openstack image create http 500 error)

asked 2019-05-13 08:29:51 -0500

carlov gravatar image

Hello,

I'm building a mini-server based on openstack: one compute, one controller and one networking. Those boards are connected to a development board, where I'm running kolla-ansible deployment sequence. While compute, networking and controller are armed by Ubuntu server 18.04, the development board is armed by Ubuntu desktop 18.04.

I'm following the environment setup instruction (as far I could see) and I have installed all requested tools pip -V : pip19.0.3 (python 2.7) docker -v: docker version 18.09.6 ansible --version: ansible 2.5.1

Any boards has one dynamic IP and two static vlan addresses, used to build internal network and VIP address.

I have also cloned the kolla-ansible locally, since the installed version gave me issue with MariaDB (timeout, during reconfigure/deploy).

  • multinode setting (what has been changed compared to the original template:

[control] XX.YY.ZZ.198 ansible_user=user ansible_password=password ansible_become=true [network] XX.YY.ZZ.157 ansible_user=user ansible_password=password ansible_become=true [compute] XX.YY.ZZ.243 ansible_user=user ansible_password=password ansible_become=true [monitoring]

select the control.

XX.YY.ZZ.198 [storage]

select the development board: XX.YY.ZZ.167

localhost ansible_connection=local become=true [deployment] localhost ansible_connection=local become=true

  • globals setting (what has been changed compared to the original template

kolla_base_distro: "ubuntu" kolla_install_type: "source" openstack_release: "rocky" kolla_internal_vip_address: "XX.YY.ZZ.99" docker_registry: "XX.YY.ZZ.167:5000" network_interface: "eno1.1" neutron_external_interface: "eno1.2" enable_cinder: "yes" enable_cinder_backend_lvm: "yes" enable_collectd: "yes" enable_gnocchi: "yes" enable_grafana: "yes" enable_heat: "yes" enable_horizon: "yes" enable_horizon_magnum: "yes" enable_horizon_tacker: "yes" enable_horizon_zun: "yes" enable_influxdb: "yes" enable_kuryr: "yes" enable_magnum: "yes" enable_swift: "yes" enable_telegraf: "yes" enable_tacker: "yes" enable_zun: "yes" swift_devices_match_mode: "strict" swift_devices_name: "KOLLA_SWIFT_DATA"

I can run the following sequence, without any error ./kolla-ansible -i multinode bootstrap-servers ./kolla-ansible -i multinode prechecks ./kolla-ansible -i multinode deploy ./kolla-ansible -i multinode post-deploy

then I can run (sudo -s) source /etc/kolla/admin-openrc.sh and ./init-runonce where I have changed the setting to match my network

After that, I can use Horizon, Grafana, everything seems to work fine, but I cannot manage images I have notice that the init-runonce file generate an error (HTTP 500) during the "openstack image create".

I have seen other cases pointing to a permission issue, but it is not simple to understand what to check in kolla-ansible deployment environment case.

Any good clue? Thanks /Carlo

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-16 07:41:47 -0500

carlov gravatar image

Hello,

this issue is now fixed: the http 500 error during the init-runonce has been generated by a mistake done during the swift objects and rings generation. I destroyed the deployment, set swift ring properly and ran a fresh installation again. No problem anymore!

BR/Carlo

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-13 08:29:51 -0500

Seen: 60 times

Last updated: May 13