Ask Your Question
0

Exception for OpenStack stein:NovaException: Upgrade DB using Essex release first. [closed]

asked 2019-05-13 04:11:28 -0500

Im installing OpenStack stein,

I got the following exception when i run

su -s /bin/sh -c "nova-manage api_db sync" nova

  NovaException: Upgrade DB using Essex release first.

there is following error in nova-manage.log

2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration     info_cache=kw.get("info_cache", None),
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration   File "<string>", line 2, in _setup_parser
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/reflection.py", line 55, in cache
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration     ret = fn(self, con, *args, **kw)
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration   File "/usr/lib64/python2.7/site-packages/sqlalchemy/dialects/mysql/base.py", line 2643, in _setup_parser
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration     connection, None, charset, full_name=full_name
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration   File "/usr/lib64/python2.7/site-packages/sqlalchemy/dialects/mysql/base.py", line 2746, in _show_create_table
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration     raise exc.NoSuchTableError(full_name)
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration DatabaseNotControlledError: `migrate_version`
2019-05-13 14:16:39.219 23945 ERROR nova.db.sqlalchemy.migration

i have gone through the solutions in the link

 https://ask.openstack.org/en/question/95282/mitaka-nova-db-sync-produces-error-upgrade-db-using-essex-release-first/

but dint solve the problem.. please help me out

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Spoorthi Vaidya
close date 2019-05-14 10:17:21.495844

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-14 10:16:26 -0500

This problem got solved. The problem was some other files related to rabbitmq and maria DB were compatible with rocky release.

So i uninstalled and installed again rabbitmq and mariaDB after updating the openstack release to Stein and ran yum update command, then the problem got solved.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-13 04:11:28 -0500

Seen: 18 times

Last updated: May 14