Ceilometer is unable to connect to gnocchi.

asked 2019-05-09 10:42:03 -0500

wahab.icp gravatar image

updated 2019-05-13 04:20:46 -0500

I am using Openstack(Rocky) on Ubuntu 18.04.

I have installed gnocchi, It is working fine.

root@controller:~# gnocchi status
+-----------------------------------------------------+-------+
| Field                                               | Value |
+-----------------------------------------------------+-------+
| metricd/processors                                  | None  |
| storage/number of metric having measures to process | 0     |
| storage/total number of measures to process         | 0     |
+-----------------------------------------------------+-------+

I have installed Ceilometer but the problem is that Ceilometer is unable to send data to gnocchi. All the metrics in gnocchi are empty.

The contents of error log /var/log/ceilometer/ceilometer-agent-notification.log are

2019-05-09 17:22:30.591 4971 ERROR ceilometer.publisher.gnocchi [-] <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at
 [no address given] to inform them of the time this error occurred,
 and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.4.29 (Ubuntu) Server at controller Port 8041</address>
</body></html>
 (HTTP 500): ClientException: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

Since in Openstack Rocky there isnt any file /etc/ceilometer/pipeline.yaml I was not able to add gnoochi pipeline to the publisher. It was suggested by the installation guide on https://docs.openstack.org/ceilometer/rocky/install/install-base-ubuntu.html (Official-Documentation)

Edit the /etc/ceilometer/pipeline.yaml file and complete the following section:

Configure Gnocchi connection:

publishers:
    # set address of Gnocchi
    # + filter out Gnocchi-related activity meters (Swift driver)
    # + set default archive policy
    - gnocchi://?filter_project=service&archive_policy=low

Question:

How can i configure successful sending of data from ceilometer to gnocchi database.?

Any help is much appreciated!

edit retag flag offensive close merge delete

Comments

I took the liberty to move your latest comment to the question.

In my opinion, the problem is not in Ceilometer, but in Gnocchi. Notice port number 8041 in the error message: The Ceilometer agent tries to talk to Gnocchi and gets a 500. Check the Gnocchi logs for more information.

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-10 07:03:15 -0500 )edit

Perhaps I am misinterpreting the output of gnocchi status, but could it be that no metricd proccess is running?

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-10 07:13:09 -0500 )edit

Thank you, @Bernd Bausch. I am not getting this error anymore, there was configuration problem in gnoochi.conf and I have also added pipeline.yaml. But i am now getting a new error. I am going to post a new question for it. Thank you.

wahab.icp gravatar imagewahab.icp ( 2019-05-13 04:18:18 -0500 )edit

Hi, I have no HTTP errors at all but I'm also unable to connect ceilometer and gnocchi. No data when I ran "gnocchi status". As per doc, to make a connection with ceilometer, we've to configure "pipeline.yaml". I did but still nothing. Have you managed to do any progress on this please? Thanks

sagargurung gravatar imagesagargurung ( 2019-08-09 05:46:43 -0500 )edit

@sagargurung You say you configured pipeline.yaml. How precisely? Did you also configure polling.yaml? And which OpenStack version is this?

If you want more people to see your problem, create a new question that contains your config details and a precise problem description.

Bernd Bausch gravatar imageBernd Bausch ( 2019-08-09 20:09:47 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-10-29 03:54:56 -0500

ykwei gravatar image

hi, how do you install gnocchi and ceilometer successfully in Rocky version?

edit flag offensive delete link more

Comments

There are many options. For example, automatic installation by Packstack or Devstack. Or the Ceilometer install guide, which covers Gnocchi as well. Gnocchi has its own install guide (http://gnocchi.xyz has DNS problems right now).

Bernd Bausch gravatar imageBernd Bausch ( 2019-10-29 04:58:24 -0500 )edit

Thank you! I followed Ceilometer install guide but failed. (There is no Gnocchi-api and Ceilometer-upgrade stuck.) So I want to check that if I follow the steps on Ceilometer install guide, whether I could successfully install.

ykwei gravatar imageykwei ( 2019-10-30 00:39:19 -0500 )edit

Admittedly I have never installed it manually and either used Devstack or Packstack.

I suggest you create a new question where you describe what you do and which steps fail.

Bernd Bausch gravatar imageBernd Bausch ( 2019-10-30 04:16:25 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-09 10:42:03 -0500

Seen: 643 times

Last updated: Oct 29 '19