Ask Your Question
0

Stein Packstack does not add NIC to br-ex

asked 2019-05-09 09:35:31 -0500

updated 2019-05-12 03:21:30 -0500

Is this a bug or user error?

I have a virtual server freshly installed with Centos 7.6, with a single NIC eth0 and IP address 10.1.1.4.

The following works nicely with Rocky on Centos 7.6:

sudo packstack --debug --allinone --default-password pw --os-neutron-ovs-bridge-interfaces=br-ex:eth0   --provision-demo-floatrange=10.1.1.0/24 --provision-demo-allocation-pools '["start=10.1.1.10,end=10.1.1.50"]' --os-heat-install=y --os-heat-cfn-install=y

Deployment succeeds. br-ex has both 10.1.1.4 and 10.1.1.1, and includes eth0 as port. The cloud works.

When installing Stein Packstack on an identical server (except different IP 10.1.1.6), the same command results in

  • br-ex with 10.1.1.1
  • eth0 still has 10.1.1.6
  • eth0 is not plugged into br-ex
  • the routing table prioritizes br-ex (which is not connected to the outside world) over eth0.

Eventually the Packstack deployment fails because repos on the internet can't be reached.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-12 02:40:21 -0500

updated 2019-05-12 02:41:10 -0500

It turns out that my problem comes from the Neutron defaults in Stein Packstack, which changed significantly from earlier releases. Notably, Stein Packstack defaults include ML2 mechanism driver OVN instead of Openvswitch, and type driver Geneve instead of VXLAN.

I solved my problem with an even longer packstack invocation, explicitly setting type and mechanism drivers and the default tenant network type, as well as the L2 agent:

sudo packstack --debug --allinone --default-password pw        \
               --os-neutron-ovs-bridge-interfaces=br-ex:eth0   \
               --os-neutron-ml2-tenant-network-types=vxlan     \
               --os-neutron-ml2-mechanism-drivers=openvswitch  \
               --os-neutron-ml2-type-drivers=vxlan,flat        \
               --os-neutron-l2-agent=openvswitch               \
               --provision-demo-floatrange=10.1.1.0/24         \
               --provision-demo-allocation-pools '["start=10.1.1.10,end=10.1.1.50"]' \
               --os-heat-install=y --os-heat-cfn-install=y

I suppose I could have reached the same result by replacing the five os-neutron options with a single --os-neutron-ovn-bridge-interfaces=br-ex:eth0 (note: ovn instead of ovs), but I have not tried this yet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-09 09:35:31 -0500

Seen: 91 times

Last updated: May 12