no process found ( nova-compute / neutron)

asked 2019-05-08 16:39:03 -0600

Abdelrahman gravatar image

Hello,

I'm trying to install OpenStack for the first time, I'm installing it on private VM behind LAN

After following this guide,

https://www.techrepublic.com/article/how-to-install-openstack-on-a-single-ubuntu-server-virtual-machine/ (https://www.techrepublic.com/article/...)

After 30 mins of exceuting the stack.sh

it stucked at

nova-compute: no process found neutron-dhcp-agent: no process found neutron-l3-agent: no process found neutron-metadata-agent: no process found

That's what I found in the logs

2019-05-07 04:05:04.431 | Error on exit 2019-05-07 04:05:04.434 | +./stack.sh:exit_trap:545 type -p generate-subunit 2019-05-07 04:05:04.438 | +./stack.sh:exit_trap:546 generate-subunit 1557200064 1840 fail 2019-05-07 04:05:04.845 | +./stack.sh:exit_trap:548 [[ -z /opt/stack/logs ]] 2019-05-07 04:05:04.848 | +./stack.sh:exit_trap:551 /master/tools/worlddump.py -d /opt/stack/logs 2019-05-07 04:05:06.007 | nova-compute: no process found 2019-05-07 04:05:06.015 | neutron-dhcp-agent: no process found 2019-05-07 04:05:06.023 | neutron-l3-agent: no process found 2019-05-07 04:05:06.035 | neutron-metadata-agent: no process found 2019-05-07 04:05:06.056 | +./stack.sh:exit_trap:560

So how can I solve this problem ?

Thank you

T

edit retag flag offensive close merge delete

Comments

I had good results following this https://www.rdoproject.org/install/pa...

give it a go.techrepublic might be out of date,,, OR might be a bug in the git repo you pulled from.

tonyp12 gravatar imagetonyp12 ( 2019-05-08 23:15:35 -0600 )edit