Ask Your Question
0

Unable to access horizon

asked 2019-05-06 03:21:30 -0500

updated 2019-05-15 02:55:16 -0500

[pid 20548] WARNING:root:Use of this 'djano.wsgi' file has been deprecated since the Rocky release in favor of 'wsgi.py' in the 'openstack_dashboard' module. This file is a legacy naming from before Django 1.4 and an importable 'wsgi.py' is now the default. This file will be removed in the T release cycle.

This is the error i found in /var/log/http/error_log

can anyone help me out.

edit retag flag offensive close merge delete

Comments

1

This is a warning, not an error. It doesn't help with your problem.

Provide more information. How did you set up your cloud, how did you connect it to the network, on what kind of server(s) does it run. Is Apache running? Is Horizon running? Does a firewall block port 80? Etc.

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-06 05:05:18 -0500 )edit

Please post the output of

openstack service list

and

openstack resource list
ARatcliff gravatar imageARatcliff ( 2019-05-06 20:56:05 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-08 03:59:57 -0500

I found the solution. There was a warning as well as script timed out error.

In the file /etc/httpd/conf.d/openstack-dashboard.conf , I have added the line:

WSGIApplicationGroup %{GLOBAL}

The problem got resolved and now i'm able to access dashboard.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-06 03:21:30 -0500

Seen: 125 times

Last updated: May 06