Ask Your Question
0

Issue With the creation of glance image-create?

asked 2014-02-18 06:20:27 -0500

ebyenjoys gravatar image

Hello Sir,

I am following the http://docs.openstack.org/havana/inst... and i got stuck in the image-create portion.

I have run the following command::

glance image-create --name="ubuntu" --disk-format=qcow2   --container-format=bare --is-public=true < precise-server-cloudimg-i386-disk1.img

And am getting the error:::

The request you have made requires authentication. (HTTP 401)

To resolve the above problem,

I have manually exported the following and still the same issue exist.

export OS_USERNAME=admin
export OS_PASSWORD=******
export OS_TENANT_NAME=admin
export OS_TENANT_NAME=service
export OS_AUTH_URL=http://192.168.1.70:35357/v2.0

Even after this i am getting the same error.

I also tried the below command and i got the same error.

glance --os-username=admin --os-password=***** --os-tenant-name=service --os-auth-url=http://192.168.1.70:5000/v2.0 image-create --name="ubuntu" --disk-format=qcow2   --container-format=bare --is-public=true < precise-server-cloudimg-i386-disk1.img

I have the following logs:-

root@ubuntu:/var/log/glance# tail -f api.log 
Exit code: 127
Stdout: ''
Stderr: '/bin/sh: 1: collie: not found\n'
2014-02-18 10:52:01.672 820 WARNING glance.store.base [-] Failed to configure store correctly: Store sheepdog            could not be configured correctly. Reason: Error in store configuration: Unexpected error while running command.
Command: collie
 Exit code: 127
Stdout: ''
Stderr: '/bin/sh: 1: collie: not found\n' Disabling add method.
2014-02-18 10:52:03.916 820 WARNING glance.store.base [-] Failed to configure store correctly: Store cinder could    not be configured correctly. Reason: Cinder storage requires a context. Disabling add method.
2014-02-18 10:52:04.258 820 WARNING glance.api.v2.images [-] Could not find schema properties file schema-  image.json. Continuing without custom properties

Kindly help me to sort this.

edit retag flag offensive close merge delete

Comments

Above error may not be a issue. It is issue of credential what you have specified. Can you give me you glance-api.conf and paste.conf. I can quickly look at and help you to resolve the issue.

dheeru gravatar imagedheeru ( 2014-02-18 08:06:28 -0500 )edit

Hello Dheeru Bro,and first of all you are truly grateful in helping in others and its so kind kind of you and really appreciate your work.Below is my glance-api.conf [keystone_authtoken] auth_uri = http://192.168.1.70:5000 auth_host = 192.168.1.70 auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = glance admin_password = ******* [paste_deploy] flavor = keystone

ebyenjoys gravatar imageebyenjoys ( 2014-02-18 12:14:25 -0500 )edit

Here is my /etc/glance/glance-api-paste.ini [filter:authtoken] paste.filter_factory=keystoneclient.middleware.auth_token:filter_factory auth_host=192.168.1.70 admin_user=glance admin_tenant_name=service admin_password=******* Its lil bit wirerd to send the conf files with comment,is there any other way? :)

ebyenjoys gravatar imageebyenjoys ( 2014-02-18 12:18:01 -0500 )edit
1

Configuration looks fine to me. Either you must be missing glance user or missing creation of user, tenant and role definition. Do you have user called as glance ? Can you give me the output of 'keystone user-list'. Can you put your configuration files in paste.openstack.org ? It is easy to put the configuration file there. I dont' know your timezone. You can ping me on dheerendra.madhusudhana@gmail.com. We can fix your issue quickly.

dheeru gravatar imagedheeru ( 2014-02-18 22:17:31 -0500 )edit
ebyenjoys gravatar imageebyenjoys ( 2014-02-19 05:13:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-02-18 08:15:09 -0500

Mathias Ewald gravatar image

Hi, in your RC file you export OS_TENANT_NAME twice. Once with "admin" and the you overwrite it with "service". So the effective tenant is "service". In your command line parameter example you are using "service", too. I believe your tenant name should be "admin". But check with keystone!

edit flag offensive delete link more

Comments

How to remove those existing credentials and replace with new one. Actually i am not an expert in creating RC file. I usually place my credentials in bashrc and i do execute the bash command. Could i remove my existing credentials with the unset command and i guess i have tried to unset them too and still no positive replies.

ebyenjoys gravatar imageebyenjoys ( 2014-02-18 12:00:11 -0500 )edit

Rc file creation requires no expertise ;) Just remove the line that sets your tenant name to "service" and source the file again (http://www.tldp.org/HOWTO/Bash-Prompt-HOWTO/x237.html). Then type "env | grep OS" an check what is currently set in your environment.

Mathias Ewald gravatar imageMathias Ewald ( 2014-02-19 04:25:45 -0500 )edit

I will surely invest my time on creating RC file sir, and as per you finding, i exported correct credentials and it worked out for me. :)

ebyenjoys gravatar imageebyenjoys ( 2014-02-20 04:51:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-18 06:20:27 -0500

Seen: 1,725 times

Last updated: Feb 18 '14