Ask Your Question
0

Openstack aio instance dns not resolve names

asked 2019-05-02 08:13:49 -0600

gorkagal gravatar image

Hi,

I have deployed with virtualbox vm an all in one openstack rocky version. I have deployed a wordpress instance via heat template. Everything is ok (I can ping/ssh to the instance), but it is not software provisioned because it does not resolve dns names. I can ping 8.8.8.8 for instance but it does not resolve http://google.com. The instance is deployed in a private network with dns-nameserver value 8.8.8.8... Any ideas about this?

Thanks!

edit retag flag offensive close merge delete

Comments

What’s the content of /etc/resolv.conf on the instance? Can you see the corresponding dnsmasq options?

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-02 09:17:05 -0600 )edit

/etc/resolv.conf search openstacklocal novalocal nameserver 8.8.8.8

where can I check dnsmasq options?

I have also made a tcpdump to see the traffic in port 53 and I do not have response from the dns nameserver to the instance.

gorkagal gravatar imagegorkagal ( 2019-05-02 09:37:05 -0600 )edit

The command lines of dnsmasq processes on the allinone server tell you which option files to check, but if 8.8.8.8 is already configured, the problem is elsewhere.

The network trace shows connection requests to 8.8.8.8:53 but no replies? Is something blocking outgoing port 53 traffic?

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-02 17:45:43 -0600 )edit

How about other ports like TCP/80 or TCP/22? Can you connect to the outside world using those?

Bernd Bausch gravatar imageBernd Bausch ( 2019-05-02 17:47:13 -0600 )edit

Network trace shows connection requests to 8.8.8.8 but not responses from there..and the other ports are ok, I can do ping/ssh from the compute node to the instance...From lxc containers I can resolve dns names but from instances not.

Network provider type? Could be something related with this?

gorkagal gravatar imagegorkagal ( 2019-05-03 01:08:31 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2019-05-03 06:50:51 -0600

gorkagal gravatar image

Solved!! I put as dns-nameserver value the same as lxc containers have in etc/resolv.conf (10.255.255.1).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-05-02 08:13:49 -0600

Seen: 71 times

Last updated: May 02