error eventlet 0.24.1

asked 2019-04-27 15:55:01 -0600

Mitos gravatar image

ContextualVersionConflict: (eventlet 0.24.1 (/usr/local/lib/python2.7/dist-packages); Requirement.parse('eventlet!=0.18.3, !=0.20.1, <0.21.0, >=0.18.2'), set(['os-win']))

edit retag flag offensive close merge delete

Comments

I have installed both python 3.5 and python 2.7 and pip 19.1. I am installing Devstack master

Mitos gravatar imageMitos ( 2019-04-27 16:06:30 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-06 11:10:47 -0600

bnemec gravatar image

It looks like os-win still caps eventlet. It should really stop doing that, but in the meantime you could try installing os-win manually before running devstack. As long as the version of eventlet it pulls in satisfies the other OpenStack projects' requirements that should get you around this.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-04-27 15:55:01 -0600

Seen: 128 times

Last updated: May 06 '19