devstack multinode - instance creation failed

asked 2019-04-21 10:03:21 -0600

sanjay khuntia gravatar image

updated 2019-04-21 10:54:53 -0600

Hi All, I have configured 2 VMs using devstack stein for a multi host setup. In this case first VM acts as a controller+compute with minimal openstack services and the 2nd VM acts as a second compute host. After configuration, I can see the horizon UI and can see 2 hosts under Hypervisor/Compute section in Horizon. However when I create a instance it shows error as -

Error: Failed to perform requested operation on instance "testvm3", the instance has an error status: Please try again later [Error: Host 'devstack-testvm-stein' is not mapped to any cell].

The instance status shows as 'Error' in Instances Section in Horizon. My second host local.conf files contains something like this which differs from my 1st controller+compute host-

#All in One setup, set controller IP as host ip addr
CONTROLLER_IP=<My_first_compute-controller_host_ip>

#Set where to look for other services
SERVICE_HOST=$CONTROLLER_IP
MYSQL_USER=admin
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST
MULTI_HOST=1
#New auth version available in newer relase only, comment below 3 lines for old releases(e.g liberty)
auth_version=v3
auth_uri=http://$SERVICE_HOST:35357/v3
OPENSTACK_KEYSTONE_URL=http://$SERVICE_HOST:35357/v3

#list of services to be disabled
disable_service n-net
disable_service n-auth
disable_service etcd3
disable_service tempest

#Enable Compute Services and disable controller services on compute
ENABLED_SERVICES=n-cpu,n-api-meta,q-agt,placement-client
 # and some additional config line...

openstack compute service command output on my 1st VM(controller+compute) shows the below output

stack@devstack-u16:~/devstack$ openstack compute service list
+----+------------------+-------------------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host                    | Zone     | Status  | State | Updated At                 |
+----+------------------+-------------------------+----------+---------+-------+----------------------------+
|  2 | nova-scheduler   | devstack-u16              | internal | enabled | up    | 2019-04-21T15:50:03.000000 |
|  5 | nova-consoleauth | devstack-u16             | internal | enabled | up    | 2019-04-21T15:49:58.000000 |
|  6 | nova-conductor   | devstack-u16              | internal | enabled | up    | 2019-04-21T15:50:01.000000 |
|  1 | nova-conductor   | devstack-u16              | internal | enabled | up    | 2019-04-21T15:49:55.000000 |
|  4 | nova-compute     | devstack-u16              | nova     | enabled | up    | 2019-04-21T15:49:57.000000 |
|  5 | nova-compute     | devstack-testvm-stein | nova     | enabled | up    | 2019-04-21T15:49:58.000000 |
+----+------------------+-------------------------+----------+---------+-------+----------------------------+

Please provide any pointer why the instance creation is failed. Thank you for your replies and help.

best regards,

edit retag flag offensive close merge delete

Comments

Thanks Bernd Bausch. It resolved my issue.

sanjay khuntia gravatar imagesanjay khuntia ( 2019-04-22 04:53:57 -0600 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2019-04-21 19:23:44 -0600

updated 2019-04-21 21:12:11 -0600

Judging from the message

Host 'devstack-testvm-stein' is not mapped to any cell

you didn’t run discover_hosts.sh as per the instructions.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-04-21 10:03:21 -0600

Seen: 100 times

Last updated: Apr 21 '19