Devstack (Rocky) & Gnocchi

asked 2019-04-18 14:15:29 -0600

PQUIGS gravatar image

Hello! I'm using devstack to install Rocky. All seems OK, but when I add Gnocchi to local.conf, it looks as though Gnocchi does not even get installed. When I issue "openstack metric list" I get:

public endpoint for metric service in RegionOne region not found

Here is the relevant section from local.conf:

GNOCCHI_DEPLOY=mod_wsgi
# enable_plugin gnocchi https://github.com/openstack/gnocchi master
enable_plugin gnocchi https://github.com/gnocchixyz/gnocchi master
enable_service gnocchi-api,gnocchi-metricd
enable_service gnocchi-grafana

# Eager 30 second pipeline interval
CEILOMETER_PIPE
LINE_INTERVAL=30
CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_service ceilometer

# Aodh
# ----
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

There is no gnocchi user, service, end point. No gnocchi processes are defined or running. There is no /etc/gnocchi directory.

I've scoured the devstack log file and there are no errors. Does the Rocky version of devstack still support gnocchi? I have an Ocata system where it works.

If anyone has suggestions/advice, I'd appreciate it!

edit retag flag offensive close merge delete

Comments

I successfully deployed Gnocchi on Rocky Devstack with these two lines.

CEILOMETER_BACKEND=gnocchi
GNOCCHI_ARCHIVE_POLICY=medium

Ceilometer's devstack script automatically installs Gnocchi the right way.

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-18 18:37:21 -0600 )edit

Note that the CEILOMETER_PIPELINE_INTERVAL in your local.conf is broken. Could this impact Ceilometer's setup?

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-18 18:41:19 -0600 )edit

Bernd; Can you explain what you mean by "is broken"?

PQUIGS gravatar imagePQUIGS ( 2019-04-19 07:53:06 -0600 )edit

Your local.conf contains

CEILOMETER_PIPE
LINE_INTERVAL=30

It’s literally broken: There is a line break in the middle of the variable.

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-19 08:50:40 -0600 )edit

Ah,ok. That was a paste error. It is correct in my local.conf. Any other thoughts? THX!!

PQUIGS gravatar imagePQUIGS ( 2019-04-19 09:11:02 -0600 )edit