devstack stable/rocky with masakari: installation issue

asked 2019-04-12 09:59:41 -0500

sanjay khuntia gravatar image

Hi All, I am trying to setup single node devstack installation using stable/rocky branch in my Ubuntu 16.04 LTS box. The installation goes well (running stack.sh) with my local.conf file using few of the openstack service enabled during setup and I can also access the horizon post installation. But when I add Masakari as a new service in the local.conf file, the installation fails in the midway giving the below errors -

Created symlink from /etc/systemd/system/multi-user.target.wants/devstack@masakari-engine.service to /etc/systemd/system/devstack@masakari-engine.service.
Cloning into '/opt/stack/masakari-dashboard'...
e05a182 Implement real time data for recovery workflow details
Ignoring Django: markers 'python_version == "3.4"' don't match your environment
Ignoring Django: markers 'python_version == "3.5"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "3.4"' don't match your environment
Ignoring SecretStorage: markers 'python_version == "3.5"' don't match your environment
Ignoring asyncio: markers 'python_version == "3.4"' don't match your environment
Ignoring asyncio: markers 'python_version == "3.5"' don't match your environment
Ignoring cmd2: markers 'python_version == "3.4"' don't match your environment
Ignoring cmd2: markers 'python_version == "3.5"' don't match your environment
Ignoring dnspython3: markers 'python_version == "3.4"' don't match your environment
Ignoring dnspython3: markers 'python_version == "3.5"' don't match your environment
Ignoring jeepney: markers 'python_version == "3.4"' don't match your environment
Ignoring jeepney: markers 'python_version == "3.5"' don't match your environment
Ignoring mypy: markers 'python_version == "3.4"' don't match your environment
Ignoring mypy: markers 'python_version == "3.5"' don't match your environment
Ignoring typed-ast: markers 'python_version == "3.4"' don't match your environment
Ignoring typed-ast: markers 'python_version == "3.5"' don't match your environment
Obtaining file:///opt/stack/masakari-dashboard
Exception:
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 335, in run
    wb.build(autobuilding=True)
  File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 521, in _prepare_file
    req_to_install.check_if_exists()
  File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1036, in check_if_exists
    self.req.name
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 558, in get_distribution
    dist = get_provider(dist)
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 432, in get_provider
    return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 859, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (openstacksdk 0.17.2 (/usr/local ...
(more)
edit retag flag offensive close merge delete

Comments

Below changes(in local.conf) works well in stable/stein devstack-

#Enable Masakari
enable_plugin masakari ${GIT_BASE}/openstack/masakari $USE_BRANCH
enable_plugin python-masakariclient ${GIT_BASE}/openstack/python-masakariclient $USE_BRANCH

but same is not working for stable/rocky devstack.

sanjay khuntia gravatar imagesanjay khuntia ( 2019-04-15 12:26:42 -0500 )edit