DevStack installation issue

asked 2019-04-09 09:23:34 -0500

Adammm gravatar image

updated 2019-04-10 04:48:18 -0500

Hello, I'm new here, I have done devstack installation (https://docs.openstack.org/devstack/l...)

I set those variables (local.conf) :

[[local|localrc]]
ADMIN_PASSWORD=my_password
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD

and then I went to Horizon http://MY_IP/dashboard/auth/login/

but I'm not able to login, webpage shows me that error : Unable to establish connection to keystone endpoint.

Should I add something else to my configuration ?? I tried to login as admin using my_password

also I tried to run some cli commands :

openstack project list
Missing value auth-url required for auth plugin password

I'm quite sure that my configuration is not complete. Please help

EDIT:

Thank you for answer,

systemctl status devstack@keystone.service
● devstack@keystone.service - Devstack devstack@keystone.service
   Loaded: loaded (/etc/systemd/system/devstack@keystone.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2019-04-09 15:20:41 UTC; 16h ago
 Main PID: 900 (uwsgi)
   Status: "uWSGI is ready"
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/system-devstack.slice/devstack@keystone.service
           ├─ 900 keystoneuWSGI master
           ├─1311 keystoneuWSGI worker 1
           └─1312 keystoneuWSGI worker 2

it indicates that my keystone service is running correctly right ?

Also I created script and run it :

cat configure_adam.sh

#[[local|localrc]]
export OS_IDENTITY_API_VERSION=3 #(defaults to 2.0)
export ADMIN_PASSWORD=MY_PASS
export DATABASE_PASSWORD=$ADMIN_PASSWORD
export RABBIT_PASSWORD=$ADMIN_PASSWORD
export SERVICE_PASSWORD=$ADMIN_PASSWORD
export OS_PROJECT_NAME=admin
export OS_USERNAME=admin
export OS_DEFAULT_DOMAIN=default
export OS_PASSWORD=MY_PASS
export HOST_IP=192.168.100.10
export SERVICE_HOST=$HOST_IP
export OS_AUTH_URL=https://$SERVICE_HOST:5000/v3.0
#export OS_AUTH_URL=http://localhost:5000/v3

Should I use localhost or just ip ?

I'm still not able login to horizon but something changed here

stack@adam:~/devstack$ openstack user list
Failed to discover available identity versions when contacting https://192.168.100.10:5000/v3.0. Attempting to parse version from URL.
Unable to establish connection to https://192.168.100.10:5000/v3.0/auth/tokens: HTTPSConnectionPool(host='192.168.100.10', port=5000): Max retries exceeded with url: /v3.0/auth/tokens (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7fdf39315e90>: Failed to establish a new connection: [Errno 111] Connection refused',))
edit retag flag offensive close merge delete

Comments

The first error probably indicates that Keystone is not running. Confirm that with systemctl devstack@keystone. Why is it not running? journalctl -u devstack@keystone.

I also suggest to add a LOGFILE directive to local.conf, so that you have stack.sh messages saved in a file.

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-09 14:51:58 -0500 )edit

The second error says that you have not set up your shell environment. See also https://docs.openstack.org/python-ope....

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-09 14:54:37 -0500 )edit

First, the only password required in the RC script is the user password.

Yes, Keystone is running, but it is not listening at 192.168.100.10:5000. The correct address and port should be in the openrc file in the devstack directory. Anyway, I recommend you use openrc instead of your own RC script.

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-10 04:45:36 -0500 )edit

I don’t remember how Devstack configures it by default, but the correct Keystone endpoint might be something like 192.168.100.10/identity rather than a port number. You can double check that in Apache’s virtualhost configuration under /etc/apache2 (assuming Ubuntu).

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-10 04:47:11 -0500 )edit

I have reinstalled openstack and used openrc file and it seems to be working. Thanks

Adammm gravatar imageAdammm ( 2019-04-10 09:13:27 -0500 )edit