(aodh) "openstack alarm list" giving - "500 internal server error"

asked 2019-04-09 01:41:34 -0500

hariprasath M gravatar image

updated 2019-04-09 02:29:59 -0500

Hi

I have installed aodh service in queens on ubuntu 16.04 after the configuration when I tried to create or list alarm its showing below error. Do I need to modify any other (aodh.api.conf) configurations. Please help on this, if any one faced this kind of errors.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator at 
 [no address given] to inform them of the time this error occurred,
 and the actions you performed just before this error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at controller Port 8042</address>
</body></html>
 (HTTP 500)

and also getting below error in

aodh-dbsync.log and aodh_error.log

ERROR aodh NoMatches: No 'aodh.storage' driver found, looking for 'mysql+pymsql'

-- Regards, Hariprasath M

edit retag flag offensive close merge delete

Comments

This message indicates something is wrong with your configuration:

ERROR aodh NoMatches: No 'aodh.storage' driver found, looking for 'mysql+pymsql'

I am confused, though, since I don't see any reference to an aodh.storage driver in the documentation. Are there other messages around this ERROR?

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-09 02:12:30 -0500 )edit

My guess: It has something to do with the database connection settings; see https://docs.openstack.org/aodh/lates....

Bernd Bausch gravatar imageBernd Bausch ( 2019-04-09 02:13:26 -0500 )edit

Hi Bernd,

Even I have the same doubt for "aodh.storage driver", configurations are made as per the openstack documents.

hariprasath M gravatar imagehariprasath M ( 2019-04-09 02:18:18 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2019-10-30 15:12:03 -0500

it could be caused by many reasons. You have to look at /var/log/aodh/api.log and systemctl status openstack-aodh-api to see the reason. In my case, memcached python library was not installed on my aodh api server so it could not store its token for keystone. This is printed out in systemctl status openstack-aodh-api I couldn't see anything in aodh/api.log about this, which is really confusing. And python-memcached should have been included as a dependency of openstack-aodh-api package or at least documented.

edit flag offensive delete link more
0

answered 2019-04-15 00:05:12 -0500

hariprasath M gravatar image

updated 2019-04-23 00:45:52 -0500

Hi

Ensure "gnocchi_external_project_owner = service" in aodh.conf and it has been fixed.

Regards, Harirprasath M

edit flag offensive delete link more
0

answered 2019-07-10 22:00:01 -0500

laohuang gravatar image

I also met this problem. maybe you should check /opt/stack/aodh/aodh.egg-info. which lost will casue this pronlem.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2019-04-09 01:41:34 -0500

Seen: 601 times

Last updated: Oct 30 '19