Ask Your Question
0

no ping to Internet from instance and neutron-gateway/0 - error “Destination Host Unreachable”

asked 2019-04-05 05:18:01 -0500

d@kj gravatar image

updated 2019-04-11 09:40:17 -0500

Same network schema shown in this https://ask.openstack.org/en/question/119783/no-ping-to-instance-from-neutron-gateway0-error-destination-host-unreachable/ (post).

IP plan:

Maas: 10.20.81.1
Juju: 10.20.81.2
Openstack: 10.20.81.21-24
External Gateway: 10.20.81.254
Private Network: 10.1.0.0/24
Instance: 10.1.0.12 - 10.20.81.220 (floating)
Internal Gateway: 10.1.0.1
Internal DHCP service: 10.1.0.10

Network topology

    10.20.81.0/24     
                              +-------------+
                                  Firewall
                                10.20.81.254
                              +-------------+
                                     | 
    +-------------------------------------------------------------+
                                  Switch 
          vlan81              vlan81                  vlan81
    +-------------------------------------------------------------+
            |                   |                   || | | |
    +--------------+     +------------+        +------------------+
    |Maas+Juju           |Juju Gui|            |Openstack
    |10.20.81.1          |10.20.81.2           |10.20.81.21-24
    +--------------+     +-------------+       +------------------+
                                                         |
                                    +--------------------------------------------+
                                    Private Subnet-1           Public Subnet-2
                                     10.1.0.0/24                10.20.81.0/24
                                     +---+----+--+              +----+------+
                                     |    |        +----+            |
                                     |    |     .1 |    |.221         |
                                     |    +--------+ VR +-------------+
                                     |             |    |
                                     +--+-+        +----+
                                     |    |
                                     |VM |
                                     |.12 |
                                     |    |
                                     +----+

This time the problem is the ping toward Internet. The Openstack instance and netron-gateway/0 can't reach the external world.

from neutron-gateway/0

ubuntu@os-compute02:~$ sudo ip netns exec qrouter-e933429f-6816-47b3-9e50-581d78243935 ping 10.20.81.254
PING 10.20.81.254 (10.20.81.254) 56(84) bytes of data.
From 10.20.81.221 icmp_seq=1 Destination Host Unreachable
From 10.20.81.221 icmp_seq=2 Destination Host Unreachable

ubuntu@os-compute02:~$ sudo ip netns exec qrouter-e933429f-6816-47b3-9e50-581d78243935 ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 10.20.81.221 icmp_seq=1 Destination Host Unreachable
From 10.20.81.221 icmp_seq=2 Destination Host Unreachable

ubuntu@os-compute02:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=120 time=16.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=120 time=17.9 ms

ubuntu@os-compute02:~$ sudo ip netns exec qrouter-e933429f-6816-47b3-9e50-581d78243935 route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.1.0.0        0.0.0.0         255.255.255.0   U     0      0        0 qr-44aa8011-cf
10.20.81.0      0.0.0.0         255.255.255.0   U     0      0        0 qg-f33e7db4-43

ubuntu@os-compute02:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.20.81.254    0.0.0.0         UG    0      0        0 br-eno2
10.4.251.0      0.0.0.0         255.255.255.0   U     0      0        0 lxdbr0
10.20.81.0      0.0.0.0         255.255.255.0   U     0      0        0 br-eno2

from instance

ubuntu@os-compute02:~$ sudo ip netns exec qrouter-e933429f-6816-47b3-9e50-581d78243935 ssh -p 22 -i ~/.ssh/u1804Key.pem ubuntu@10.1.0.12 -v
O
Welcome to Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-33-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

  System information as of Fri Apr  5 09:50:37 UTC 2019

  System load:  0.0               Processes:           90
  Usage of /:   1.2% of 77.36GB   Users logged in:     0
  Memory usage: 12%               IP address for ens2: 10.1.0.20 ...
(more)
edit retag flag offensive close merge delete

Comments

Hey did you got it working? Let me know thanks

rafi gravatar imagerafi ( 2019-04-09 19:11:04 -0500 )edit

no, at moment any solution found. I've tried also to change the type of external network, flat and VLAN, but nothing in the both case I've the same issue.

d@kj gravatar imaged@kj ( 2019-04-10 07:43:28 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2019-04-10 09:59:51 -0500

rafi gravatar image

Hi, I was having the same issues before, for some reason, Ubuntu doesn't tell you everything in their documentation. Any way I can look at your environment? from the neutron box show me your ifconfig,ovs-vsclt show and your netplan config. also, do a ifconfig from any compute note only 1 is fine.

edit flag offensive delete link more

Comments

1

From your neutron box let me see (ifconfig,ovs-vsctl show, and cat /etc/netplan/98....) make sure the external nic is configured correctly under your physnet1 this is very important.

rafi gravatar imagerafi ( 2019-04-10 20:20:19 -0500 )edit

here is the screen of neutron-gateway/0 https://paste.ubuntu.com/p/RqSJnwFFQr/ and the following is the ifconfig on nova-compute/0 https://paste.ubuntu.com/p/47BJvqyNmb/

d@kj gravatar imaged@kj ( 2019-04-11 09:43:53 -0500 )edit
1

Thanks, The problem is you're using eno2 as your internal cloud communication and external at the same time (I think there's a way to get it working but your deployment is for 2 separate networks. eno3 should be your (provider nic = external nic) br-ex= eno3 then manual config bridge in neutron box

rafi gravatar imagerafi ( 2019-04-11 11:20:52 -0500 )edit
1

go to juju gui and change the setting in neutron service for physnet to point to eno3 then you need to manually add the bridge in netplan in neutron to match eno3 with an ip only at the bridge side, not the nic the nic doesn't have to be configured when is on bridge mode.

rafi gravatar imagerafi ( 2019-04-11 11:25:42 -0500 )edit
1

I would reconfigure the cloud fresh with new settings, remember eno3 make it unconfig at the maas on all nodes and eno3 need internet connection to a router directly or from your firewall.

rafi gravatar imagerafi ( 2019-04-11 11:30:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-04-05 05:18:01 -0500

Seen: 71 times

Last updated: Apr 11