Ask Your Question
0

RDO(Stein) supported Python version

asked 2019-04-01 07:07:04 -0500

smaruoka gravatar image

updated 2019-04-04 00:43:56 -0500

Hello RDO Manager

I would like to know RDO (Stein) supported Python version to evaluate the plugin driver of cinder volume on RDO (Stein) environment. I understand that RDO (Rocky) supports Python2.x and OpenStack Stein will support Python3.x.

[Question] 1. Please tell us the supported Python version of RDO (Stein). Which one(a) or b) or c)) is correct? a) Python2.x or Python3.x b) Python2.x only c) Python3.x only

Best Regards. Shinji Maruoka.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-04-04 10:59:40 -0500

zaneb gravatar image

First, a correction: upstream OpenStack is tested on Python 2.7 and 3.5 in Rocky, and Python 2.7 and 3.6 in Stein. The first Python3-only release of OpenStack will be the 'U' release.

RDO is mainly tested on Python 2.7. I believe there has been some work on Python3 support in Fedora, but I wouldn't expect it to be nearly as well-tested as 2.7 until CentOS 8 is released.

edit flag offensive delete link more

Comments

Hello Zaneb-san Thank you for your valuable information!. I appreciate your response. I understood it.

Best Regards. Shinji maruoka.

smaruoka gravatar imagesmaruoka ( 2019-04-05 04:04:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-04-01 07:03:49 -0500

Seen: 67 times

Last updated: Apr 04