Packstack installation error: Error while evaluating a Function Call, no address for at ///manifests/neutron/ovs_agent.pp:49:27

asked 2019-03-29 07:00:03 -0500

Hi All,

I am new to Openstack and currently trying to build a lab setup at home. Tried installing Packstack and get the following error:

ERROR : Error appeared during Puppet run: 192.168.16.147_compute.pp Error: Evaluation Error: Error while evaluating a Function Call, no address for at /var/tmp/packstack/5d5173e8f8124561b04fc34651b914be/modules/packstack/manifests/neutron/ovs_agent.pp:49:27 on node localhost.localdomain

Some additional details on Interface config and answers file:

root@localhost ~]# ip link show

2: ens33: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000 link/ether 00:0c:29:5a:79:c7 brd ff:ff:ff:ff:ff:ff 3: ens38: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast master ovs-system state UP mode DEFAULT group default qlen 1000 link/ether 00:0c:29:5a:79:d1 brd ff:ff:ff:ff:ff:ff 8: ovs-system: <broadcast,multicast> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 link/ether ba:11:76:20:8d:a4 brd ff:ff:ff:ff:ff:ff 9: br-ens38: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 link/ether 00:0c:29:5a:79:d1 brd ff:ff:ff:ff:ff:ff 10: br-ex: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 link/ether b6:10:a0:e6:ef:46 brd ff:ff:ff:ff:ff:ff

[root@localhost ~]# cat answers.txt | grep NEUTRON_OVS CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-ens38 CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-ens38:ens38 CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE= CONFIG_NEUTRON_OVS_EXTERNAL_PHYSNET=extnet CONFIG_NEUTRON_OVS_TUNNEL_IF=ens38 CONFIG_NEUTRON_OVS_TUNNEL_SUBNETS= CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789

Appreciate if anyone help to fix this issue. ens33 (external network), ens38 (internal network).

Thanks, Dharmesh

edit retag flag offensive close merge delete

Comments

I think you have to set a hostname for the server and ensure that it resolves to an IP address, either using DNS or /etc/hosts.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-29 17:43:37 -0500 )edit