Ask Your Question
2

[VMWare][Ubuntu][Devstack] external access to private network does not work

asked 2014-02-15 11:14:16 -0500

Nicolas gravatar image

updated 2014-02-15 14:36:01 -0500

Hi,

After looking into lots of website, forums i haven't been able to find more information that could explain my challenge. I'm kind of a beginner with Devstack/openstack and start to become nuts with this network issue. Any helps / hints would be much appreciated.

I'm using VMWare workstation on my laptop to host a Ubuntu VM running devstack. So far everything works except external access to/from the private network: - My VMs deployed in devstack can speak to each other and ping the router (which is properly setup as a default gw) - My VMs deployed in devstack can not speak to anything in the Public network - Nothing in my public network can reach my VM deployed in devstack

from the devstack host (10.0.100.4 is a devstack VM in the private network): nicolas@ubuntu-devstack:~/devstack$ ping 10.0.100.4

PING 10.0.100.4 (10.0.100.4) 56(84) bytes of data.
From 192.168.143.210 icmp_seq=1 Destination Host Unreachable
From 192.168.143.210 icmp_seq=2 Destination Host Unreachable
From 192.168.143.210 icmp_seq=3 Destination Host Unreachable

from a VM to try to reach a server on the public network

I can't copy/paste it but when i try to ping 192.168.143.1 sitting in the public network: from 10.0.100.1 (my router interface on the private network) Destination Net unreachable

Some information on what i've done: On my ubuntu :

nicolas@ubuntu-devstack:~/devstack$ uname -a
Linux ubuntu-devstack 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

net.ipv4.conf.eth0.proxy_arp = 1
net.ipv4.ip_forward = 1
sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

Here is my localrc file for devstack

nicolas@ubuntu-devstack:~/devstack$ cat localrc
HOST_IP=192.168.143.210
FLOATING_RANGE=192.168.143.224/27
FIXED_RANGE=10.0.100.0/24
FIXED_NETWORK_SIZE=256
NETWORK_GATEWAY=10.0.100.1
FLAT_INTERFACE=eth0
ADMIN_PASSWORD=cnicolas
MYSQL_PASSWORD=cnicolas
RABBIT_PASSWORD=cnicolas
SERVICE_PASSWORD=cnicolas
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
## Neutron . Neutron L4/L7 Network Service
#enable_service q-lbaas

# Optional, to enable tempest configuration as part of devstack
enable_service tempest
SERVICE_TOKEN=tokentoken

#the default pvs/lvs created by devstack is not big enough (pvs = 10Gb and it creates a 1G partition out of it)
VOLUME_BACKING_FILE_SIZE=60000M

#Enable logging in a file instead of having to use screen -r
SCREEN_LOGDIR=/opt/stack/logs/screen

./stack.sh run without issues and based on Horizon UI, all services are up and running.

----IFCONFIG OUTPUT--------

nicolas@ubuntu-devstack:~/devstack$ ifconfig -a
br-ex     Link encap:Ethernet  HWaddr c6:73:30:31:3e:42
          inet addr:172.24.4.1  Bcast:0.0.0.0  Mask:255.255.255.224
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-02-20 06:09:49 -0500

Nicolas gravatar image

Found the solution, it was a design issue ...

FLOATING_RANGE=192.168.143.224/27

Here we should not specify the subnet that the Ubuntu VM has access to. we need to provide another subnet. By removing this line, devstack automatically use 172.24.4.0/24 for the public network.

this give the following topology: 192.168.143.0/24 Network <-> Ubuntu VM Eth0 <-> 172.24.4.0/24 <->br-ex interface

and everything work

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-15 11:14:16 -0500

Seen: 4,616 times

Last updated: Feb 20 '14