[kolla] Disabling haproxy does not work

asked 2019-03-20 01:42:39 -0500

vblando gravatar image

Environment: Ubuntu Version: Queens

I have a 2 node deployment and I disabled haproxy in globals.yml but for some reason it does not doing what it's supposed to do.

An error on the deployment run reveals that MariaDB is trying to connect to a VIP

TASK [mariadb : Waiting for MariaDB service to be ready through VIP] ********************************************************************************************************************************
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (6 retries left).
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (5 retries left).
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (4 retries left).
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (3 retries left).
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (2 retries left).
FAILED - RETRYING: Waiting for MariaDB service to be ready through VIP (1 retries left).
fatal: [192.168.0.115]: FAILED! => {"attempts": 6, "changed": false, "cmd": ["docker", "exec", "mariadb", "mysql", "-h", "192.168.0.199", "-P", "3306", "-u", "haproxy", "-e", "show databases;"], "delta": "0:00:03.093026", "end": "2019-03-20 02:11:02.423933", "msg": "non-zero return code", "rc": 1, "start": "2019-03-20 02:10:59.330907", "stderr": "ERROR 2003 (HY000): Can't connect to MySQL server on '192.168.0.199' (113 \"No route to host\")", "stderr_lines": ["ERROR 2003 (HY000): Can't connect to MySQL server on '192.168.0.199' (113 \"No route to host\")"], "stdout": "", "stdout_lines": []}

enabling haproxy fixes it.

edit retag flag offensive close merge delete